加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

1121 Damn Single (25 分)

发布时间:2020-12-14 04:22:53 所属栏目:大数据 来源:网络整理
导读:"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party,so they can be taken care of. Input Specification: Each input file contains one test case. For each

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party,so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case,the first line gives a positive integer N (≤50,000),the total number of couples. Then N lines of the couples follow,each gives a couple of ID‘s which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples,there is a positive integer M (≤?10,000) followed by M ID‘s of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line,print their ID‘s in increasing order. The numbers must be separated by exactly 1 space,and there must be no extra space at the end of the line.

Sample Input:

3
22222 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 22222 23333

Sample Output:

5
10000 23333 44444 55555 88888
//初始化用用-1
//因为有人的编号可能是00000
//所以第二个点不过 
#include<cstdio>
const int maxn = 100010;

int spouse[maxn] = {0};

int main(){
    int n,id1,id2;
    for(int i = 0; i < maxn; i++) spouse[i] = -1; 
    scanf("%d",&n);
    while(n--){
        scanf("%d%d",&id1,&id2);
        spouse[id1] = id2;
        spouse[id2] = id1;  
    }
    scanf("%d",&n);
    while(n--){
        scanf("%d",&id1);
        if(spouse[id1] >= 0 && spouse[spouse[id1]] >= 0){
            spouse[id1] = -2;
        }else if(spouse[id1] >= 0 &&spouse[spouse[id1]] == -2){
            spouse[spouse[id1]] = 2;
        }else{
            spouse[id1] = -3;
        }
    }
    int cnt = 0;
    for(int i = 0; i < maxn; i++){
        if(spouse[i] < -1) cnt++;
    }
    printf("%dn",cnt);
    for(int i = 0; i < maxn; i++){
        if(spouse[i] < -1){
            printf("%05d",i);
            cnt--;
            if(cnt > 0) printf(" ");
        }    
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读