加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

(hdu 2.3.2)Exponentiation(大数:求R的n次幂)

发布时间:2020-12-14 02:47:46 所属栏目:大数据 来源:网络整理
导读:在写题解之前给自己打一下广告哈~ 。。抱歉了,希望大家多多支持我在CSDN的视频课程,地址如下: http://edu.csdn.net/course/detail/209 题目: ? ? ? ?? Exponentiation Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

在写题解之前给自己打一下广告哈~

。。抱歉了,希望大家多多支持我在CSDN的视频课程,地址如下:

http://edu.csdn.net/course/detail/209


题目:

? ? ? ??

Exponentiation

Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1938 Accepted Submission(s): 527
?
Problem Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example,the computation of the national debt is a taxing experience for many computer systems.?

This problem requires that you write a program to compute the exact value of R n?where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.?
?
Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6,and the n value will be in columns 8 and 9.
?
Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
?
Sample Input
95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12
?
Sample Output
548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201
?
?
Source
East Central North America 1988
?
Recommend
PrincetonBoy
?


题目分析:

? ? ? ? ? ? ? ?简单题。大数的基本使用。求R的n次幂。



代码如下:

import java.math.BigDecimal;
import java.util.Scanner;


public class Main {

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		
		while(scanner.hasNext()){
			BigDecimal r = scanner.nextBigDecimal();//对于求R^n的这种大数题。r要以BigDecimal的形式读进来.否则会出现各种各样的问题
			int n = scanner.nextInt();
			
			r = r.pow(n);
			
			/**
			 * stripTrailingZeros(): 去掉末尾无效0
			 * toPlainString(): 由科学计数法转为普通的计数法
			 * 如将给一个字符串1.238761976E-10
			 * 转化成0.0000000001238761976
			 */
			String result = r.stripTrailingZeros().toPlainString();
		    if(result.startsWith("0.")){//用于处理0.XXX情况
		    	result = result.substring(1);
		    }
			
		    System.out.println(result);
		}
	}
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读