加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdoj 1047 Integer Inquiry(几个大数连续加)

发布时间:2020-12-14 02:19:34 所属栏目:大数据 来源:网络整理
导读:Integer Inquiry Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 15840????Accepted Submission(s): 4068 Problem Description One of the first users of BIT's new supercomputer was Chip D

Integer Inquiry

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15840????Accepted Submission(s): 4068


Problem Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.)
?

Input
The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.
?

Output
Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N,then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
?

Sample Input
  
  
1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
?

Sample Output
  
  
370370367037037036703703703670
按照大数加做就行了!、
代码:
#include<stdio.h>
#include<string.h>
int main()
{
	int n,k=0;
	scanf("%d",&n);
	while(n--)
	{
		int i,j,flag=1;
		char ch[1010];
		int s[1010],c[1010];
		memset(s,sizeof(s));
		memset(c,sizeof(c));//清零 
		while(scanf("%s",ch)!=EOF&&strcmp(ch,"0")!=0)
		{
			flag=0;
			int l=strlen(ch);
			for(i=0,j=l-1;i<l;i++)// 大数加模板 
			{
				c[j--]=ch[i]-'0';
			}
			for(i=0;i<l;i++)
			 {
			 	s[i]+=c[i];
			 	if(s[i]>=10)
			 	{
				 s[i+1]++;
			 	 s[i]-=10;
				 }
			 }
		}
		if(flag)//判断是否只有一个数0 
		printf("0n");
		else
		{
		for(i=1000;i>=0;i--)
		if(s[i]!=0)
		break;
		for(;i>=0;i--)
		printf("%d",s[i]);
		printf("n");
	    }
	    k++;
	    if(n!=0)//注意格式 
	    printf("n");
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读