加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

大数相乘

发布时间:2020-12-14 05:09:59 所属栏目:大数据 来源:网络整理
导读:Given two integers,? a ?and? b ,you should check whether? a ?is divisible by? b ?or not. We know that an integer? a ?is divisible by an integer? b ?if and only if there exists an integer? c ?such that? a = b * c . Input Input starts with a

Given two integers,?a?and?b,you should check whether?a?is divisible by?b?or not. We know that an integer?a?is divisible by an integer?b?if and only if there exists an integer?c?such that?a = b * c.

Input

Input starts with an integer?T (≤ 525),denoting the number of test cases.

Each case starts with a line containing two integers?a (-10200?≤ a ≤ 10200)?and?b (|b| > 0,b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case,print the case number first. Then print?‘divisible‘?if?a?is divisible by?b. Otherwise print?‘not divisible‘.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

就是判断前边的数字是否可以被后边的整除,,要按照字符串的格式处理

#include<iostream>
#include<string>
using namespace std;
int main(){
    int t,k=0;
    cin>>t;
    while(t--){
        k++;
        string a;
        int b;
        cin>>a>>b;
        long long ans=0,i=0;
        if(a[0]==-) i++;
        for(;i<a.size();i++){
            ans=(ans*10+a[i]-0)%b;
        }
        printf("Case %d: ",k);
        if(ans==0)puts("divisible");
        else puts("not divisible");
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读