加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

Binary Search

发布时间:2020-12-14 04:33:06 所属栏目:大数据 来源:网络整理
导读:Search II You are given a sequence of? n ?integers S and a sequence of different? q ?integers T. Write a program which outputs C,the number of integers in T which are also in the set S. Input In the first line? n ?is given. In the second l

Search II

You are given a sequence of?n?integers S and a sequence of different?q?integers T. Write a program which outputs C,the number of integers in T which are also in the set S.

Input

In the first line?n?is given. In the second line,?n?integers are given. In the third line?q?is given. Then,in the fourth line,?q?integers are given.

Output

Print C in a line.

Constraints

  • Elements in S is sorted in ascending order
  • n ≤ 100000
  • q ≤ 50000
  • 0 ≤ an element in S ≤ 109
  • 0 ≤ an element in T ≤ 109

Sample Input 1

5
1 2 3 4 5
3
3 4 1

Sample Output 1

3

Sample Input 2

3
1 2 3
1
5

Sample Output 2

0

Sample Input 3

5
1 1 2 2 3
2
1 2

Sample Output 3

2

#include <iostream>
using namespace std;
int a[100010],b[50010];
int n,q;

int binarySearch(int c)
{
	int mid;
	int left = 0,right = n - 1;
	while(left <= right)
	{
		mid = left + (right - left) / 2;
		if(a[mid] == c)	
		{
			return 1;
		}
		else if(c < a[mid]) 
		{
			right = mid - 1;
		}
		else 
		{
			left = mid + 1;
		}
	}
	
	return 0;	
}

int main()
{
	int sum = 0;
	cin >> n;
	for(int i = 0; i < n; ++ i)
		cin >> a[i];
	
	cin >> q;
	for(int i = 0; i < q; ++ i)
	{
		cin >> b[i];
		if(binarySearch(b[i]))	sum ++;
	}
	
	cout << sum << endl;
	
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读