加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

Children’s Queue

发布时间:2020-12-14 04:10:30 所属栏目:大数据 来源:网络整理
导读:Children’s Queue Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8419????Accepted Submission(s): 2665 Problem Description There are many students in PHT School. One day,the headmast

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8419????Accepted Submission(s): 2665


Problem Description
There are many students in PHT School. One day,the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words,either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF,FFFM,MFFF,FFMM,MFFM,MMFF,MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
?

Input
There are multiple cases in this problem and ended by the EOF. In each case,there is only one integer n means the number of children (1<=n<=1000)
?

Output
For each test case,there is only one integer means the number of queue satisfied the headmaster’s needs.
?

Sample Input
  
  
1 2 3
?

Sample Output
  
  
1 2 4
?
#include<iostream>
using namespace std;
int f[1005][1201];
int main()
{
	
	int i,j;
	memset(f,sizeof(f));
	f[1][1200]=1;
	f[2][1200]=2;
	f[3][1200]=4;
	f[4][1200]=7;
	//printf("111n");
	for(i=5;i<=1000;i++)
	{
		for(j=1200;j>=0;j--)
		{
			f[i][j]=f[i-1][j]+f[i-2][j]+f[i-4][j];
		}
		for(j=1200;j>=0;j--)
		{
			if(f[i][j]/10>0)
			{
			    f[i][j-1]+=f[i][j]/10;
				f[i][j]%=10;
			}
		}
	}
	int n;
	while(scanf("%d",&n)>0)
	{
		for(j=0;j<=1200;j++)
			if(f[n][j]!=0)
				break;
			for(;j<=1200;j++)
		printf("%d",f[n][j]);
			printf("n");
	}
	return 0;
}
 

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读