加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdu 1250 Hat's Fibonacci(大数加法)

发布时间:2020-12-14 04:04:08 所属栏目:大数据 来源:网络整理
导读:Problem Description A Fibonacci sequence is calculated by adding the previous two members the sequence,with the first two members being both 1. F(1) = 1,F(2) = 1,F(3) = 1,F(4) = 1,F(n4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4) Your task is to


Problem Description

A Fibonacci sequence is calculated by adding the previous two members the sequence,with the first two members being both 1. F(1) = 1,F(2) = 1,F(3) = 1,F(4) = 1,F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4) Your task is to take a number as input,and print that Fibonacci number.

Input

Each line will contain an integers. Process to end of file.

Output

For each case,output the result in a line.

Sample Input

100

Sample Output

4203968145672990846840663646?
Note: No generated Fibonacci number in excess of 2005 digits will be in the test data,ie. F(20) = 66526 has 5 digits.
?
代码:
#include <iostream>
#include<cstdio>
#include<cmath>
#include<string.h>
#define MAXI 7050

using namespace std;

void bigadd(char a[],char b[],char c[])
{
    int i,j,la,lb,lc,flag=0,k=0;
    char t;
    i=strlen(a)-1;
    j=strlen(b)-1;
    while(i>=0&&j>=0)
    {
        t=a[i--]+b[j--]+flag-'0';
        flag=(t-'0')/10;
        t=t-flag*10;
        c[k++]=t;
    }
    while(i>=0)
    {
        t=a[i--]+flag;
        flag=(t-'0')/10;
         t=t-flag*10;
        c[k++]=t;
    }
    while(j>=0)
    {
        t=b[j--]+flag;
        flag=(t-'0')/10;
         t=t-flag*10;
        c[k++]=t;
    }
    if(flag)
	{c[k]=flag+'0'; c[k+1]='';}
    else
	{ k--;c[k+1]='';}
    for(i=0,j=strlen(c)-1;i<j;i++,j--)
    {
        t=c[i];c[i]=c[j];c[j]=t;
    }
 
}

char a[MAXI][2050],c[2050],d[2050];

int main()
{
   int i,n;
   strcpy(a[1],"1");
   strcpy(a[2],"1");
   strcpy(a[3],"1");
   strcpy(a[4],"1");
   for(i=5;i<MAXI;i++)
   {
   bigadd(a[i-1],a[i-2],c);
   bigadd(c,a[i-3],d);
   bigadd(d,a[i-4],a[i]);
   }
    
   while(~scanf("%d",&n))
   {
	   printf("%sn",a[n]);}
return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读