加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

PAT 1086 Tree Traversals Again[中序转后序][难]

发布时间:2020-12-14 03:47:04 所属栏目:大数据 来源:网络整理
导读:1086?Tree Traversals Again(25?分) An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example,suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed,the stack ope
1086?Tree Traversals Again(25?分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example,suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed,the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case,the first line contains a positive integer?N?(30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to?N). Then?2N?lines follow,each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case,print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space,and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

?题目大意:二叉树的中根遍历,可以通过栈来实现,那么现在给出一棵二叉树的中根遍历操作,要求输出后根遍历结果。

//完全可以通过输入来确定这棵二叉树的中根遍历,即已知中根遍历求后根遍历。但是我不会啊。

?代码转自:

#include <cstdio>
#include <vector>
#include <stack>
#include <cstring>
using namespace std;
vector<int> pre,in,post,value;
void postorder(int root,int start,int end) {
    if (start > end) return;
    int i = start;
    while (i < end && in[i] != pre[root]) {//中序遍历序列中存的节点的id,唯一的!
        i++;
        printf("%d %dn",in[i],pre[root]);
    }
    postorder(root + 1,start,i - 1);
    //左子树共有i-start+1个节点。
    postorder(root + 1 + i - start,i + 1,end);
    post.push_back(pre[root]);
}
int main() {
    int n;
    scanf("%d",&n);
    char str[5];
    stack<int> s;
    int key=0;
    while (~scanf("%s",str)) {
        if (strlen(str) == 4) {
            int num;
            scanf("%d",&num);
            value.push_back(num);
            pre.push_back(key);//对应num有一个序号,从0开始。

            s.push(key++);
        } else {
            in.push_back(s.top());//现在存了中序遍历
            //存的是id对应的序号(为了防止重复呢。)
            s.pop();
        }
    }

    postorder(0,0,n - 1);
    printf("n");
    printf("%d",value[post[0]]);
    for (int i = 1; i < n; i++)
        printf(" %d",value[post[i]]);
    return 0;
}

?

//这个代码简直太难了,看了好几遍都理解不了那个中序转后序的,气死了。

//这个明天还要搜一下别的题解,简直气死我了。

//更要重点掌握一套,二叉树的各种访问序列转换方法。

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读