加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

PAT 1138 Postorder Traversal

发布时间:2020-12-14 03:45:54 所属栏目:大数据 来源:网络整理
导读:Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences,you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences,you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case,the first line gives a positive integer N (≤ 50,000),the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case,print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

#include<iostream> //海星
#include<vector>
using namespace std;
vector<int> pre,in;
int flag=0;
void solve(int lb,int le,int rb,int re){
    if(lb>le)
        return ;
    if(lb==le&&flag++==0)
        cout<<pre[lb]<<endl;
    int i=rb;
    while(i<=re&&in[i]!=pre[lb]) i++;
    solve(lb+1,lb+i-rb,rb,i-1);
    solve(lb+i-rb+1,le,i+1,re);
}
int main(){
    int n;
    cin>>n;
    pre.resize(n),in.resize(n);
    for(int i=0; i<n; i++)
        cin>>pre[i];
    for(int i=0; i<n; i++)
        cin>>in[i];
    solve(0,n-1,n-1);
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读