加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU 1013_Digital Roots(大数&模拟)

发布时间:2020-12-14 03:33:48 所属栏目:大数据 来源:网络整理
导读:Digital Roots Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 47146????Accepted Submission(s): 14605 点击打开题目 Problem Description The digital root of a positive integer is found

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47146????Accepted Submission(s): 14605

点击打开题目
Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits,those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example,consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit,6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit,the process must be repeated. Adding the 1 and the 2 yeilds 3,a single digit and also the digital root of 39.
?

Input
The input file will contain a list of positive integers,one per line. The end of the input will be indicated by an integer value of zero.
?

Output
For each integer in the input,output its digital root on a separate line of the output.
?

Sample Input
  
  
24 39 0
?

Sample Output
  
  
6 3
?

Source
Greater New York 2000

不断把各个位上的数相加,直到得到一个个位数。
代码:
#include <iostream>
#include<cstdio>
using namespace std;
long long int check(long long int n)
{
    long long int a;
    long long int s=0;
    for(;;)
    {
        a=n%10;
        s=s+a;
        if(n/10==0)
            break;
        n=n/10;
    }
    return s;
}
int main()
{
    long long int i;
    long long int s;
    char c[1000];
    while(scanf("%s",c)!=EOF&&c[0]!='0')//字符串输入解决大数问题
    {
        s=0;
       for(i=0;c[i]!='';i++)
       {
           s=s+c[i]-'0';//变为整数
       }
        while(s/10!=0)//循环模拟过程,求解
        {
            s=check(s);
        }
        cout<<s<<endl;
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读