加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdu 1042 N!(大数阶乘)

发布时间:2020-12-14 03:32:51 所属栏目:大数据 来源:网络整理
导读:链接:hdu 1042 Problem Description Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N! ? Input One N in one line,process to the end of file. ? Output For each N,output N! in one line. ? Sample Input 123 ? Sample Output 126 ?

链接:hdu 1042

Problem Description
Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N!
?

Input
One N in one line,process to the end of file.
?

Output
For each N,output N! in one line.
?

Sample Input
  
  
1 2 3
?

Sample Output
  
  
1 2 6
?
模拟算数乘法,将每一位与乘数相乘,记录进位。

AC代码:
#include<stdio.h>
#include<string.h>
int s[10010];
int main()
{
    int i,j,n,m,c;
    while(scanf("%d",&n)!=EOF){
        memset(s,sizeof(s));
        s[0]=1;
        c=0;
        for(i=2;i<=n;i++)
            for(j=0;j<=10000;j++){
                m=s[j]*i+c;
                s[j]=m%10000;       //如果用char 处理,m只需对10取余或除以10
                c=m/10000;
        }
        for(i=10000;i>=0;i--)        //处理前导0
            if(s[i]!=0)
                break;
        printf("%d",s[i]);         //不能有前导0
        for(i--;i>=0;i--)
            printf("%04d",s[i]);      //中间的0不能省略
        printf("n");
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读