加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU 1212 Big Number 大数求余数

发布时间:2020-12-14 03:31:40 所属栏目:大数据 来源:网络整理
导读:Big Number Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4522????Accepted Submission(s): 3129 Problem Description As we know,Big Number is always troublesome. But it's really impor

Big Number

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4522????Accepted Submission(s): 3129

Problem Description
As we know,Big Number is always troublesome. But it's really important in our ACM. And today,your task is to write a program to calculate A mod B.
To make the problem easier,I promise that B will be smaller than 100000.
Is it too hard? No,I work it out in 10 minutes,and my program contains less than 25 lines.
Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000,and B will be smaller than 100000. Process to the end of file.
Output
For each test case,you have to ouput the result of A mod B.
Sample Input
  
  
2 3 12 7 152455856554521 3250
Sample Output
  
  
2 5 1521

/*
HDU 1212 Big Number (大数的余数)
看别人的 
举个例子,1314 % 7= 5
1314= ((1*10+3)*10+1)*10+4
所以有
1314 % 7= (((1 * 10 % 7 +3 )*10 % 7 +1)*10 % 7 +4)%7
*/
#include<iostream>
#include<cstring>
using namespace std;

int main(){
    
    int i,num,pos,n;
    char str[1001];
    while(scanf("%s%d",str,&n)!=EOF)
    {    
        num=0;
        for(i=0;i<strlen(str);i++)
        {
            num=(num*10+str[i]-'0')%n;
        }
        printf("%dn",num);
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读