加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU1316:How Many Fibs?(大数JAVA)

发布时间:2020-12-14 03:30:01 所属栏目:大数据 来源:网络整理
导读:L -? How Many Fibs? Time Limit: 1000 MS????? Memory Limit: 32768 KB????? 64bit IO Format: %I64d %I64u Submit ? Status Description Recall the definition of the Fibonacci numbers:? f1 := 1? f2 := 2? fn := fn-1 + fn-2 (n = 3)? Given two numbe
L -?How Many Fibs?
Time Limit:1000MS?????Memory Limit:32768KB?????64bit IO Format:%I64d & %I64u
Submit? Status

Description

Recall the definition of the Fibonacci numbers:?
f1 := 1?
f2 := 2?
fn := fn-1 + fn-2 (n >= 3)?

Given two numbers a and b,calculate how many Fibonacci numbers are in the range [a,b].?
?

Input

The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise,a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.?
?

Output

For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.?
?

Sample Input

       
       
10 100 1234567890 9876543210 0 0
?

Sample Output

5 4
?
题意:大于a小于b的斐波那契数个数
分析:大数,用JAVA吧
代码:
import java.io.*;
import java.math.*;
import java.util.*;
import java.text.*;
 
public class Main {
 
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        BigInteger[] dp = new BigInteger[1000];
        dp[1] = BigInteger.ONE;
        dp[2] = BigInteger.ONE.add( BigInteger.ONE );
        dp[3] = dp[1].add(dp[2]);
        int i;
        for (i = 3; i <= 500; ++i) {
            dp[i] = dp[i - 1].add(dp[i - 2]);
        }
        BigInteger l,r;
        while (in.hasNextBigInteger()) {
            int cnt = 0;
            l = in.nextBigInteger();
            r = in.nextBigInteger();
            if (BigInteger.ZERO.equals(l) && BigInteger.ZERO.equals(r)) {
                break;
            }
            for (int j = 1; j <= 500; ++j) {
                if(dp[j].compareTo(r)>0){
                        break;
                }
                if(dp[j].compareTo(l)>=0){
                        cnt++;
                }
            }
            System.out.println(cnt);
        }
        System.exit(0);
    }
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读