加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

大数 A + B 【杭电-HDOJ-1002】 附题

发布时间:2020-12-14 03:27:43 所属栏目:大数据 来源:网络整理
导读:/* A + B Problem II Time Limit: 2000/1000 MS (Java/Others)??? Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 210207??? Accepted Submission(s): 40482 Problem Description I have a very simple problem for you. Given two intege

/*
A + B Problem II
Time Limit: 2000/1000 MS (Java/Others)??? Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 210207??? Accepted Submission(s): 40482


Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.

?

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

?

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

?

Sample Input
2
1 2
112233445566778899 998877665544332211
?

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 2222222222222221110

#include<stdio.h>
#include<string.h>
#define N 1000
int main(){
	int n;
		while(~scanf("%d",&n)){
			//吞掉回车符 
		      getchar();
		      int i,j,k,a,b,t;
		     //数组定义 
	         char schar1[N+10];
	         char schar2[N+10];
	         int sint1[N+10];
	         int sint2[N+10];
		     for(k=1;k<=n;k++){
			 	memset(sint1,sizeof(sint1));//只能初始化int型 
                memset(sint2,sizeof(sint2));   	
		     	scanf("%s %s",schar1,schar2);
		        a=strlen(schar1);
		        b=strlen(schar2);
		       
		        //反转赋值 
		        for(i=0; i<a; i++)
		            sint1[a-1-i]=schar1[i]-'0';//一层循环 
		        
		        for(i=0; i<b; i++)
		            sint2[b-1-i]=schar2[i]-'0';
		        //将a定义为a,b中最大的 
		        if(a<b){
		        	t=a;
		        	a=b;
		        	b=t;
		        }
		        //判断是否进位 
		        for(i=0;i<=a;i++){
			       sint1[i]+=sint2[i];
			       if(sint1[i]>9){
			 	      sint1[i]-=10;
				      sint1[i+1]++;      //此处不是i++ 
			       }
		        }
						     
		   	    printf("Case %d:n%s + %s = ",schar2);
		   	    //判断是否有进位,不同情况不同输出 
                if(sint1[a]==0){
				    for(i=a-1;i>=0;i--)       //逆序输出 
                        printf("%d",sint1[i]); 
                        printf("n");       //这个printf不在for循环内部     
                }    				
                if(sint1[a]!=0){
                	for(i=a;i>=0;i--)
                        printf("%d",sint1[i]);
                        printf("n");      //这个printf不在for循环内部 
                }                 
                if(k!=n) printf("n");   //最后一个不换行             
			 }
	    }
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读