加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

大数对小数取余

发布时间:2020-12-14 03:11:07 所属栏目:大数据 来源:网络整理
导读:Problem Description As we know,Big Number is always troublesome.But it's really important in our ACM. And today,your task is to write aprogram to calculate A mod B. To make the problem easier,I promise that B will be smaller than 100000. I

Problem Description

As we know,Big Number is always troublesome.But it's really important in our ACM. And today,your task is to write aprogram to calculate A mod B.

To make the problem easier,I promise that B will be smaller than 100000.

Is it too hard? No,I work it out in 10 minutes,and my program contains lessthan 25 lines.

Input

The input contains several testcases. Each test case consists of two positive integers A and B. The length ofA will not exceed 1000,and B will be smaller than 100000. Process to the endof file.

Output

For each test case,you have toouput the result of A mod B.

Sample Input

2 3
12 7
152455856554521 3250

Sample Output

2
5
1521

A*B % C = (A%C * B%C)%C

(A+B)%C = (A%C + B%C)%C

如 532 mod 7 =(500%7+30%7+2%7)%7;

由此可得大数的每一位对小数求余最后结果再对小数求余就是大数对小数求余的结果

#include<stdio.h>
#include<string.h>
int main()
{
	char str[1000];
	int a,i,len,sum;
	while(scanf("%s%d",str,&a)!=EOF)
	{
		sum=0;
		len=strlen(str);
		for(i=0;i<len;i++)
		{
			sum=(sum*10+str[i]-'0')%a;
		}
		printf("%dn",sum);
	}
	return 0;
} 

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读