加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU 2424-Gary's Calculator(表达式计算+大数)

发布时间:2020-12-14 03:00:06 所属栏目:大数据 来源:网络整理
导读:Gary's Calculator Time Limit: 5000/1000 MS (Java/Others)????Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 950????Accepted Submission(s): 209 Problem Description Gary has finally decided to find a calculator to avoid making

Gary's Calculator

Time Limit: 5000/1000 MS (Java/Others)????Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 950????Accepted Submission(s): 209


Problem Description
Gary has finally decided to find a calculator to avoid making simple calculational mistakes in his math exam. Unable to find a suitable calculator in the market with enough precision,Gary has designed a high-precision calculator himself. Can you help him to write the necessary program that will make his design possible?
For simplicity,you only need to consider two kinds of calculations in your program: addition and multiplication. It is guaranteed that all input numbers to the calculator are non-negative and without leading zeroes.
?

Input
There are multiple test cases in the input file. Each test case starts with one positive integer N (N < 20),followed by a line containing N strings,describing the expression which Gary's calculator should evaluate. Each of the N strings might be a string representing a non-negative integer,a "*",or a "+". No integer in the input will exceed 10 9.
Input ends with End-of-File.
?

Output
For each test case,please output one single integer (with no leading zeros),the answer to Gary's expression. If Gary's expression is invalid,output "Invalid Expression!" instead. Please use the format indicated in the sample output.?
?

Sample Input
  
  
3 100 + 600 3 20 * 4 2 + 500 5 20 + 300 * 20
?

Sample Output
  
  
Case 1: 700 Case 2: 80 Case 3: Invalid Expression! Case 4: 6020
给出一个只含+和*的表达式,求其值。由于数据太大,使用BigInteger 。 可以采用栈来计算表达式,先算*,后算+;
import java.io.*;
import java.util.*;
import java.math.*;

public class Main {
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		int n,cas = 1;
		while (in.hasNext()) {
			n = in.nextInt();
			String[] s = new String[n];
			for (int i = 0; i < n; i++)
				s[i] = in.next();
			int flag = 1;
			if (n % 2 == 0)
				flag = 0;
			for (int i = 0; i < n; i++) {
				if ((i % 2 == 1 && s[i].charAt(0) != '+' && s[i].charAt(0) != '*')
						|| (i % 2 == 0 && (s[i].charAt(0) == '+' || s[i]
								.charAt(0) == '*')))
					flag = 0;
			}
			System.out.print("Case " + cas + ": ");
			cas++;
			if (flag == 0 || n == 0) {
				System.out.println("Invalid Expression!");
				continue;
			}
			Stack stack = new Stack();
			for (int i = 0; i < n; i++) {
				int tag = 0;
				if (s[i].charAt(0) != '+' && s[i].charAt(0) != '*') {
					if (stack.size() != 0) {
						String t = stack.peek().toString();
						if (t.charAt(0) == '*') {
							stack.pop();
							if (stack.size() != 0) {
								String tt = stack.pop().toString();
								BigInteger a = new BigInteger(s[i].toString());
								BigInteger b = new BigInteger(tt.toString());
								stack.push(a.multiply(b).toString());
								tag = 1;
							}
						}
					}
				}
				if (tag == 0)
					stack.push(s[i]);
			}
			BigInteger res = BigInteger.ZERO;
			while (stack.size() != 0) {
				String x = stack.pop().toString();
				if (x.charAt(0) != '+') {
					res = res.add(new BigInteger(x));
				}
			}
			System.out.println(res);
		}
	}
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读