加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU-求大数的阶乘

发布时间:2020-12-14 02:48:47 所属栏目:大数据 来源:网络整理
导读:问题及代码: /* *Copyright (c)2014,烟台大学计算机与控制工程学院 *All rights reserved. *文件名称:HDU.cpp *作 者:单昕昕 *完成日期:2015年1月27日 *版 本 号:v1.0 *问题描述:Time Limit : 10000/5000ms (Java/Other) Memory Limit : 65536/32768K
问题及代码:
/*  
*Copyright (c)2014,烟台大学计算机与控制工程学院  
*All rights reserved.  
*文件名称:HDU.cpp  
*作    者:单昕昕  
*完成日期:2015年1月27日  
*版 本 号:v1.0  
*问题描述:Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 22   Accepted Submission(s) : 4
Font: Times New Roman | Verdana | Georgia 
Font Size: ← →
Problem Description
Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N!
*程序输入:One N in one line,process to the end of file.
*程序输出:For each N,output N! in one line.

Sample Input
1
2
3

Sample Output
1
2
6
*/
#include<iostream>
#include<cstdio>
using namespace std;
int a[40000];
int main()
{
    int i,j,n,carry;
    while(~scanf("%d",&n))
    {
        a[0]=1,a[1]=1;
        if(n==0 || n==1)
        {
            printf("1n");
            continue;
        }
        for(i=2; i<=n; ++i)
        {
            carry=0;
            for(j=1; j<=a[0]; ++j)
            {
                int temp=a[j]*i+carry;
                carry=temp/10;
                a[j]=temp%10;
            }
            while(carry)
            {
                a[j]=carry%10;
                a[0]=j;
                carry/=10;
                j++;
            }
        }
        for(i=a[0]; i>=1; --i)
            printf("%d",a[i]);
        puts("");
    }
    return 0;
}



运行结果:



知识点总结:
求大数的阶乘,要分离开一部分一部分做。

学习心得:

千万不要想着能暴力破解,我试着用unsigned long long型来测试最大数据长度,结果最大只能算到65!,再大的话就显示是0了。

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读