杭电1212 Big Number (大数求模运算)
Big NumberTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Problem Description As we know,Big Number is always troublesome. But it’s really important in our ACM. And today,your task is to write a program to calculate A mod B. To make the problem easier,I promise that B will be smaller than 100000. Is it too hard? No,I work it out in 10 minutes,and my program contains less than 25 lines. Input The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000,and B will be smaller than 100000. Process to the end of file. Output For each test case,you have to ouput the result of A mod B. Sample Input
2 3
12 7
152455856554521 3250
Sample Output 2 5 1521 Author Source 解题思想: abc%m=(a*100+b*10+c)%m
=(a*100%m+b*10%m+c%m)%m
所以我们可以先求出10^1………10^Length of A 对m的求模结果,保存到N[1001]数组中。 代码如下: #include<stdio.h>
#include<iostream>
using namespace std;
int N[1001];
char str[1001];
int main()
{
int m,num=1,res;
while(cin>>str>>m)
{
int len=strlen(str)-1;
res=0;
for(int i=0;i<=len;i++)
{
int x=str[len-i]-'0';
num*=10;
num%=m;
if(i==0) num=1;
N[i]=num;
res+=x*N[i];
if(res>m) res%=m;
}
cout<<res<<endl;
}
return 0;
}
题目链接:
(编辑:李大同) 【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容! |