加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDOJ 1212 Big Number(大数版同余定理)

发布时间:2020-12-14 02:27:34 所属栏目:大数据 来源:网络整理
导读:Big Number Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5916????Accepted Submission(s): 4135 Problem Description As we know,Big Number is always troublesome. But it's really impor

Big Number

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5916????Accepted Submission(s): 4135


Problem Description
As we know,Big Number is always troublesome. But it's really important in our ACM. And today,your task is to write a program to calculate A mod B.

To make the problem easier,I promise that B will be smaller than 100000.

Is it too hard? No,I work it out in 10 minutes,and my program contains less than 25 lines.
?

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000,and B will be smaller than 100000. Process to the end of file.
?

Output
For each test case,you have to ouput the result of A mod B.
?

Sample Input
  
  
2 3 12 7 152455856554521 3250
?

Sample Output
  
  
2 5 1521
?

乍一看还以为是大数相减,通过不断相减得到小于n的值,即余数。准备敲时,感觉会超时,放弃了。

?

正解则是使用同余定理不断对s取模。

?

这一题用了以下两个同余定理公式:

????????????? (A?+?B)?mod?M?=?(?A?mod?M?+?B?mod?M?)?mod?M
????????????????????????????????????????????????????????????????????

??????????????(A?*?B)?mod?M?=?((A?mod?M)?*(?B?mod?M))?mod?M??


代码如下:

?

#include<cstdio>
#include<cstring>
int main()
{
	int n,len,i,ans;
	char str[1010];
	while(scanf("%s%d",str,&n)!=EOF)
	{
		len=strlen(str);
		ans=0;
		for(i=0;i<len;i++)
		{
			ans=ans*10+(str[i]-'0');
			ans=ans%n;
		}
		printf("%dn",ans);
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读