加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

Tiling POJ 2506 【大数】

发布时间:2020-12-14 02:23:32 所属栏目:大数据 来源:网络整理
导读:http://poj.org/problem?id=2506 Description In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?? Here is a sample tiling of a 2x17 rectangle.? Input Input is a sequence of lines,each line containing an integer number 0 = n =

http://poj.org/problem?id=2506


Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles??
Here is a sample tiling of a 2x17 rectangle.?


Input

Input is a sequence of lines,each line containing an integer number 0 <= n <= 250.

Output

For each line of input,output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.?

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

做之前看看这个:http://www.voidcn.com/article/p-srgjmibb-cr.html

n==0时输出1 神数据,wa了n次这个地方


//贴两种大数进位方式

#include<stdio.h>
#include<string.h>
int a[300][2010];
void fun()
{
	int i,j;
	memset(a,sizeof(a));
	a[0][0]=1;
	a[1][0]=1;
	a[2][0]=3;
	int t;
	for(i=3;i<=260;++i)
	{
		int k=0;
		for(j=0;j<=2000;++j)
		{
			a[i][j] += a[i-1][j] + 2 * a[i-2][j];		
			if(a[i][j]>=10) 
			{
				a[i][j+1]=a[i][j]/10;
				a[i][j]%=10;
			}
		}
	}
}
int main()
{
	int n,i;	
	fun();
	while(~scanf("%d",&n))
	{
		for(i=2000;i>0&&a[n][i]==0;--i);
		for(;i>=0;--i)
			printf("%d",a[n][i]);
		printf("n");
	}
	return 0;
}



#include<stdio.h>
#include<string.h>
int a[300][2010];
void fun()
{
	int i,sizeof(a));
	a[0][0]=1;
	a[1][0]=1;
	a[2][0]=3;
	int t;
	for(i=3;i<=260;++i)
	{
		int k=0;
		for(j=0;j<=2000;++j)
		{
			t = a[i-1][j] + 2 * a[i-2][j] + k;
			k=t / 10;
			a[i][j]=t%10;
		}
	}
}
int main()
{
	int n,a[n][i]);
		printf("n");
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读