加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU 1212 Big Number 【大数】

发布时间:2020-12-14 02:27:16 所属栏目:大数据 来源:网络整理
导读:Big Number Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5984????Accepted Submission(s): 4182 Problem Description As we know,Big Number is always troublesome. But it's really impor

Big Number

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5984????Accepted Submission(s): 4182


Problem Description
As we know,Big Number is always troublesome. But it's really important in our ACM. And today,your task is to write a program to calculate A mod B.

To make the problem easier,I promise that B will be smaller than 100000.

Is it too hard? No,I work it out in 10 minutes,and my program contains less than 25 lines.
?

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000,and B will be smaller than 100000. Process to the end of file.
?

Output
For each test case,you have to ouput the result of A mod B.
?

Sample Input
  
  
2 3 12 7 152455856554521 3250
?

Sample Output
  
  
2 5 1521
?

Author
Ignatius.L
?

Source
杭电ACM省赛集训队选拔赛之热身赛
?

思路:

???? 对大数取余,需要将大数(原来在字符串中的)转换到整型数组里面,从最高位开始对正整数c取余,最终输出c的余数就行了!

代码:

?

#include <stdio.h>
#include <string.h>
#define N 1005
char a[N];
int b[N];
int main()
{
	int len,n,i,j,k,t,s,c;
	while(scanf("%s%d",a,&c)!=EOF)
	{
		memset(b,sizeof(b));
		len=strlen(a);
	    for(i=0;i<len;i++)//将位将字符转换成数字,保存到整形数组里面!(注:a[0]保存的是最高位!) 
	       b[i]=a[i]-'0';
	    for(i=0,t=0;i<len;i++)	
	    {
	    	
	          t=t*10+b[i];	
	          t=t%c;//从最高位开始逐位对c取余! 
	    }
	    printf("%dn",t);
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读