加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

杭电1002 大数相加

发布时间:2020-12-14 02:26:50 所属栏目:大数据 来源:网络整理
导读:Problem Description I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B. ? Input The first line of the input contains an integer T(1=T=20) which means the number of test cases. Then T
Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
?


Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
?


Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
?


Sample Input
2
1 2
112233445566778899 998877665544332211
?


Sample Output
Case 1:
1 + 2 = 3


Case 2:

112233445566778899 + 998877665544332211 = 2222222222222221110


解题策略:

此题细节方面一定要注意。

1.用字符数组装数字。

2.字符型不可以和数值型一样相加减,先转换成数值型,即减去‘0’或者减去0的ASCLL码值也可以。

3.细节方面的空格一定注意,否则一直PE。


#include<stdio.h>
#include<math.h>
#include<ctype.h>
#include<string.h>
#define MAXN 5000

int max(int lena,int lenb)
{
	return (lena>=lenb?lena:lenb);
}

int main()
{
	int k,lena,lenb,T,i,j,num;
	char a[MAXN],b[MAXN],sum[MAXN];
	scanf("%d",&T);
	k=1;
	while(T--)
	{
		memset(sum,sizeof(sum));
		scanf("%s",a);
		scanf("%s",b);
		lena=strlen(a);
		lenb=strlen(b);
		num=max(lena,lenb);
		for(i=lena-1;i>=0;i--)
		{
			sum[lena-i-1]+=a[i]-'0';  //字符型不可以和数值型一样相加减,要先转换成数值型 
		}
		for(i=lenb-1;i>=0;i--)
		{
			sum[lenb-i-1]+=b[i]-'0';
		}
		for(i=0;i<=num;i++)
		{
			if(sum[i]>=10)
			{
				sum[i]-=10;
				sum[i+1]++;	
			}
			
		}
		for(i=num;i>=0;i--)
		{
			if(sum[i])
			break;
		}
		printf("Case %d:n",k++);
		printf("%s + %s = ",a,b);  //数字之前要有空格,很坑爹,很细节 
		for(j=i;j>=0;j--)
		{
			printf("%d",sum[j]);
		}
		printf("n");  //一定要仔细观察格式问题,因为没有注意到这里还有空行,WA了两次,一直PE 
		if(T)   //这个地方也是一个注意怎么处理回车的问题 
		printf("n");
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读