加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdu 1212 Big Number 大数取模

发布时间:2020-12-14 02:24:32 所属栏目:大数据 来源:网络整理
导读:Description As we know,Big Number is always troublesome. But it’s really important in our ACM. And today,your task is to write a program to calculate A mod B. To make the problem easier,I promise that B will be smaller than 100000. Is it

Description
As we know,Big Number is always troublesome. But it’s really important in our ACM. And today,your task is to write a program to calculate A mod B.

To make the problem easier,I promise that B will be smaller than 100000.

Is it too hard? No,I work it out in 10 minutes,and my program contains less than 25 lines.

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000,and B will be smaller than 100000. Process to the end of file.

Output
For each test case,you have to ouput the result of A mod B.

Sample Input
2 3
12 7
152455856554521 3250

Sample Output
2
5
1521

大数取模

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
#include<stack>
#pragma comment(linker,"/STACK:102400000,102400000")
#define pi acos(-1.0)
#define EPS 1e-6
#define INF (1<<24)
using namespace std;
int main()
{
    char A[1005];
    int mod;
    while(scanf("%s %d",A,&mod)!=EOF)
    {
        int len=strlen(A);
        int i;
        int sum=0;
        for(i=0;i<len;i++)
        {
            sum=sum*10+A[i]-'0';
            sum=sum%mod;
        }
        printf("%dn",sum);
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读