加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdoj1002A + B Problem II

发布时间:2020-12-14 02:21:03 所属栏目:大数据 来源:网络整理
导读:A + B Problem II Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 266282????Accepted Submission(s): 51573 Problem Description I have a very simple problem for you. Given two integers

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 266282????Accepted Submission(s): 51573


Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
?

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
?

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
?

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
?

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 2222222222222221110
??? 一看就是大数!!
? 代码:
?
#include<stdio.h>
#include<string.h>
char  al[1010],bl[1010];
int a[1010],b[1010];
int main()
{
    int i,j,n;
    scanf("%d",&n);
    getchar();
    int k=1;
     while(n--)
    {
        scanf("%s",al);//存为字符串 
        scanf("%s",bl);
        int l1=strlen(al);
        int l2=strlen(bl);
        memset(a,sizeof(a));//初始化 
        memset(b,sizeof(b));
        printf("Case %d:n",k++);
        for(j=0,i=l1-1;i>=0;i--)//转化为数字 
          {
              a[j]=al[i]-'0';
              j++;
          }
          for(j=0,i=l2-1;i>=0;i--)
           {
               b[j]=bl[i]-'0';
               j++;
           }
           for(i=0;i<1009;i++)//位位相加 
              {
                  a[i]=a[i]+b[i];
                  if(a[i]>=10)
                  {
                      a[i]-=10;
                     a[i+1]++;//如果大于十下一位加一 
                }
              }
              printf("%s + %s = ",al,bl);
              for(i=1009;i>=0;i--)
              {
                  if(a[i]!=0)//去掉前导零 
                    break;
              }
              if(i>=0)
               for(;i>=0;i--)
                 {
                     printf("%d",a[i]);
                 }
                 printf("n"); 
                 if(n!=0)
                 printf("n");
    }
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读