加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

Hat's Fibonacci 1250 (大数+数学 好题)

发布时间:2020-12-14 02:20:47 所属栏目:大数据 来源:网络整理
导读:Hat's Fibonacci Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9381????Accepted Submission(s): 3060 Problem Description A Fibonacci sequence is calculated by adding the previous two

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9381????Accepted Submission(s): 3060


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence,with the first two members being both 1.
F(1) = 1,F(2) = 1,F(3) = 1,F(4) = 1,F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input,and print that Fibonacci number.
?

Input
Each line will contain an integers. Process to end of file.
?

Output
For each case,output the result in a line.
?

Sample Input
  
  
100
?

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data,ie. F(20) = 66526 has 5 digits.
#include<stdio.h>
#include<string.h>
int a[10100][510];
int main()
{
	int n,i,j;
	a[1][0]=a[2][0]=a[3][0]=a[4][0]=1;
	for(i=5;i<=10000;i++)
	{
		for(j=0;j<=500;j++)
			a[i][j]=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j];
		for(j=0;j<=500;j++)
		{
			if(a[i][j]>=1000000)
			{
				a[i][j+1]+=a[i][j]/1000000;
				a[i][j]%=1000000;
			}
		}
	}
	while(scanf("%d",&n)!=EOF)
	{
		i=500;
		while(a[n][i]==0)
			i--;
			printf("%d",a[n][i]);
		while(--i>=0)
			printf("%06d",a[n][i]);
		printf("n");
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读