加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

杭电1002(简单的大数)

发布时间:2020-12-14 02:16:53 所属栏目:大数据 来源:网络整理
导读:Problem Description I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B. Input The first line of the input contains an integer T(1=T=20) which means the number of test cases. Then T li

Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case,you should output two lines. The first line is “Case #:”,# means the number of the test case. The second line is the an equation “A + B = Sum”,Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 2222222222222221110

由于涉及数据的长度约为1000,因此用数组保存数据。由低到高一位一位相加,注意进位,尤其是最高位的进位。此外,本题的格式注意在输出A + B = Sum中间是有空格的,最后一个实例输出后只有一个换行,没有空行。其余任意两个实例之间有空行。

#include<stdio.h>
#include<string.h>

char a[1010],b[1010];
int c[1010],d[1010];

int main()
{
    int T,len1,len2,len,i,j,k;
    scanf("%d",&T);
    for(k=1;k<=T;k++)
    {
        memset(a,0,sizeof(a));
        memset(b,sizeof(b));
        memset(c,sizeof(c));
        memset(d,sizeof(d));
        scanf("%s%s",a,b);
        len1=strlen(a);
        len2=strlen(b);
        len=len1>len2?len1:len2;
        for(i=len1-1,j=0;i>=0;i--,j++)
        {
            c[j]=a[i]-'0';
        }
        for(i=len2-1,j++)
        {
            d[j]=b[i]-'0';
        }
        int temp=0;
        for(i=0;i<=len;i++)
        {
            int sum=d[i]+c[i]+temp;
            d[i]=sum%10;
            temp=sum/10;
        }

        for(i=len;i>=0;i--)
        {
            if(d[i]!=0)
                break;
        }
        printf("Case %d:n%s + %s = ",k,b);
        for(j=i;j>=0;j--)
            printf("%d",d[j]);
        if(k==T)
            printf("n");
        else
            printf("nn");
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读