加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU 1865 1sting(大数斐波那契数列,模拟加法)

发布时间:2020-12-14 02:13:19 所属栏目:大数据 来源:网络整理
导读:1sting Time Limit: 5000/1000 MS (Java/Others)????Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4306????Accepted Submission(s): 1634 Problem Description You will be given a string which only contains ‘1’; You can merge tw

1sting

Time Limit: 5000/1000 MS (Java/Others)????Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4306????Accepted Submission(s): 1634


Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’,or leave the ‘1’ there. Surly,you may get many different results. For example,given 1111,you can get 1111,121,112,211,22. Now,your work is to find the total number of result you can get.
?

Input
The first line is a number n refers to the number of test cases. Then n lines follows,each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
?

Output
The output contain n lines,each line output the number of result you can get .
?

Sample Input
  
  
3 1 11 22222
?

Sample Output
  
  
1 2 8
?


Author
z.jt
?


看懂题意以后,可以先推一下 111 和 1111的数量,不难推导出 111 的结果为 3 ,1111的结果为 4,因此可以得出,这道题是个递推题,递推公式就是斐波那契数列,但是,有一个难点就是要推出前 200 项的 ?,这样 ?long long ?的范围也肯定会超,所以就需要用到大数加法了


用二维数组,一维作为标记,二维作为储存


附上代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <string>

using namespace std;

int main()
{
	int s[250][50] = {0};         //  这里面我定义的数字为最长为50位,害怕不够的可以定义的大些,不过第 200 项的 数位是22 位
	s[1][0] = 1;
	s[2][0] = 2;
	s[3][0] = 3;
	for(int j = 4;j < 201;j++)
	{
		int jin = 0;
		for(int i = 0;i < 50;i++)
        {
            s[j][i] = s[j - 1][i] + s[j - 2][i] + jin;
            jin = 0;
            if(s[j][i] > 9 && i < 49)
            {
                jin = s[j][i]/10;
                s[j][i] = s[j][i]%10;
            }
        }
	}
	int t;
	cin >> t;
	while(t--)
	{
		char str[250];
		cin >> str;
		int flag = 0;
		for(int i = 49;i >= 0;i--)
		{
			if(s[strlen(str)][i] == 0 && flag == 0)           //  除去前面的 0
			{
				continue;
			}
			flag = 1;
			cout << s[strlen(str)][i];
		}
		cout << endl;
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读