加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 百科 > 正文

数据结构实验之查找一:二叉排序树

发布时间:2020-12-15 04:50:46 所属栏目:百科 来源:网络整理
导读:? ? ? ? ? ? ? ? ? 数据结构实验之查找一:二叉排序树 Problem Description 对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样

? ? ? ? ? ? ? ? ? 数据结构实验之查找一:二叉排序树

Problem Description

对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。

Input

输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。


简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。

Output

对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出"Yes",否则输出"No"。

Sample Input

4 2

3 1 4 2

3 4 1 2

3 2 4 1

2 1

2 1

1 2

Sample Output

Yes

No

No

# include

# include

# include

struct node

{

int data;

struct node *l,*r;

};

int k,l,a[1100],b[1100];

struct node *creat(struct node *root,int x)

{

if(root==NULL)

{

root=(struct node *)malloc(sizeof(struct node));

root->data=x;

root->l=NULL;

root->r=NULL;

}

else

{

if(xdata)

root->l=creat(root->l,x);

else

root->r=creat(root->r,x);

}

return root;

}

void str1(struct node *root)

{

if(root)

{

a[k++]=root->data;

str1(root->l);

str1(root->r);

}

}

void str2(struct node *root)

{

if(root)

{

b[l++]=root->data;

str2(root->l);

str2(root->r);

}

}

int main()

{

int i,n,m,x;

struct node *root,*root1;

while(~scanf("%d%d",&n,&m)&&n)

{

root=NULL;

for(i=0; i

{

scanf("%d",&x);

root=creat(root,x);

}

k=0;

memset(a,sizeof(a));

str1(root);

while(m--)

{

l=0;

root1=NULL;

for(i=0; i

{

scanf("%d",&x);

root1=creat(root1,x);

}

memset(b,sizeof(b));

str2(root1);

for(i=0; i

{

if(a[i]!=b[i])

break;

}

if(i==n)

printf("Yesn");

else

printf("Non");

}

}

return 0;

}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读