加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 百科 > 正文

ZOJ 3818 正则表达式

发布时间:2020-12-14 01:38:41 所属栏目:百科 来源:网络整理
导读:Pretty Poem Time Limit: 2 Seconds Memory Limit: 65536 KB Poetry is a form of literature that uses aesthetic and rhythmic qualities of language. There are many famous poets in the contemporary era. It is said that a few ACM-ICPC contestants
Pretty Poem

Time Limit: 2 Seconds Memory Limit: 65536 KB

Poetry is a form of literature that uses aesthetic and rhythmic qualities of language. There are many famous poets in the contemporary era. It is said that a few ACM-ICPC contestants can even write poetic code. Some poems has a strict rhyme scheme like "ABABA" or "ABABCAB". For example,"niconiconi" is composed of a rhyme scheme "ABABA" with A = "ni" and B = "co".

More technically,we call a poem pretty if it can be decomposed into one of the following rhyme scheme: "ABABA" or "ABABCAB". The symbolA,B and C are different continuous non-empty substrings of the poem. By the way,punctuation characters should be ignored when considering the rhyme scheme.

You are given a line of poem,please determine whether it is pretty or not.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a line of poem S (1 <= length(S) <= 50). S will only contains alphabet characters or punctuation characters.

Output

For each test case,output "Yes" if the poem is pretty,or "No" if not.

Sample Input

3
niconiconi~
pettan,pettan,tsurupettan
wafuwafu

Sample Output

Yes
Yes
No



唉,逗逼一开始没想到用正则,C++各种WA。


import java.io.File;
import java.util.Scanner;
import java.util.regex.Pattern;
public class Main {
	
	Scanner in; 
	boolean debug = true;
	public void go()throws Exception
	{
		debug = false;
		File file = new File("C:UsersAdminDesktopin.txt");
		if(!debug)
			in = new Scanner(System.in);
		else in = new Scanner(file);
		int t; t = in.nextInt();
		while(t-- > 0)
		{
			String str = in.next();
			boolean flag = false;
			str = str.replaceAll("W|_","");
			for(int i = 1; i <= str.length(); i++)
			{
				String a = str.substring(0,i);
				for(int j = i+1; j <= str.length(); j++)
				{
					String b = str.substring(i,j);
					if(a.equals(b)) continue;
					Pattern pat = Pattern.compile(a+b+a+b+a);
					Pattern pat2 = Pattern.compile(a+b+a+b+"w+"+a+b);
					Pattern pat3 = Pattern.compile(a+b+a+b+b+a+b);
					Pattern pat4 = Pattern.compile(a+b+a+b+a+a+b);
					boolean ok = pat3.matcher(str).matches() || pat4.matcher(str).matches();
					if(!ok && (pat.matcher(str).matches() || pat2.matcher(str).matches()))
					{
						flag = true;
					}
				}
			}
			if(flag)
			{
				System.out.println("Yes");
			}
			else
				System.out.println("No");
		}
	}
	public static void main(String[] args) throws Exception
	{
		Main ma = new Main();
		ma.go();
	}
}


??

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读