加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 百科 > 正文

HDU 5718 Oracle

发布时间:2020-12-12 16:42:36 所属栏目:百科 来源:网络整理
导读:Problem Description There is once a king and queen,rulers of an unnamed city,who have three daughters of conspicuous beauty. The youngest and most beautiful is Psyche,whose admirers,neglecting the proper worship of the love goddess Venus,i
Problem Description There is once a king and queen,rulers of an unnamed city,who have three daughters of conspicuous beauty.

The youngest and most beautiful is Psyche,whose admirers,neglecting the proper worship of the love goddess Venus,instead pray and make offerings to her. Her father,the king,is desperate to know about her destiny,so he comes to the Delphi Temple to ask for an oracle.

The oracle is an integer n without leading zeroes.

To get the meaning,he needs to rearrange the digits and split the number into <b>two positive integers without leading zeroes</b>,and their sum should be as large as possible.

Help him to work out the maximum sum. It might be impossible to do that. If so,print `Uncertain`.
Input The first line of the input contains an integer T (1T10) ,which denotes the number of test cases.

For each test case,the single line contains an integer n (1n<1010000000) .
Output For each test case,print a positive integer or a string `Uncertain`.
Sample Input
  
  
   
   3
112
233
1
  
  

Sample Output
  
  
   
   22 35 Uncertain 
   
    
     
     Hint 
     In the first example,it is optimal to split $ 112 $ into $ 21 $ and $ 1 $,and their sum is $ 21 + 1 = 22 $. In the second example,it is optimal to split $ 233 $ into $ 2 $ and $ 33 $,and their sum is $ 2 + 33 = 35 $. In the third example,it is impossible to split single digit $ 1 $ into two parts. 
   
   
   

简单题,先判断是否有两个非零数,然后就是取一个最小的出来加进去

#include<set>
#include<map>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,k) for (int i = j; i >= k; i--)
using namespace std;
const int low(int x) { return x&-x; }
const int N = 1e7 + 10;
const int INF = 0x7FFFFFFF;
int T,n,m,f[10],a[N];
char s;

int main()
{
    scanf("%d",&T);    getchar();
    while (T--)
    {
        //scanf("%d%d",&n,&m);
        memset(f,sizeof(f));
        while ((s = getchar()) <= '9' && s >= '0') f[s - '0']++;
        int sum = 0;
        rep(i,1,9) sum += f[i];
        if (sum < 2) printf("Uncertainn");
        else
        {
            int t = 0,k = 0;
            rep(i,9) if (f[i]) { f[i]--; k = i; break; }
            rep(i,9) while (f[i]--) a[t++] = i;
            rep(i,t - 1)
            {
                int kk = a[i];
                a[i] = (a[i] + k) % 10;
                k = (k + kk) / 10;
            }
            if (k) a[t++] = k;
            while (t--) printf("%d",a[t]);
            putchar(10);
        }
    }
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读