加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 百科 > 正文

hdoj57718【Oracle】

发布时间:2020-12-12 16:15:20 所属栏目:百科 来源:网络整理
导读:Oracle Time Limit: 8000/4000 MS (Java/Others)Memory Limit: 262144/262144 K (Java/Others) Total Submission(s): 738Accepted Submission(s): 322 Problem Description There is once a king and queen,rulers of an unnamed city,who have three daught

Oracle

Time Limit: 8000/4000 MS (Java/Others)Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 738Accepted Submission(s): 322


Problem Description There is once a king and queen,rulers of an unnamed city,who have three daughters of conspicuous beauty.

The youngest and most beautiful is Psyche,whose admirers,neglecting the proper worship of the love goddess Venus,instead pray and make offerings to her. Her father,the king,is desperate to know about her destiny,so he comes to the Delphi Temple to ask for an oracle.

The oracle is an integer n without leading zeroes.

To get the meaning,he needs to rearrange the digits and split the number into <b>two positive integers without leading zeroes</b>,and their sum should be as large as possible.

Help him to work out the maximum sum. It might be impossible to do that. If so,print `Uncertain`.
Input The first line of the input contains an integer T (1T10) ,which denotes the number of test cases.

For each test case,the single line contains an integer n (1n<1010000000) .
Output For each test case,print a positive integer or a string `Uncertain`.
Sample Input
  
  
   
   3
112
233
1
  
  

Sample Output
  
  
   
   22
35
Uncertain


   
    
     
     Hint 
     In the first example,it is optimal to split $ 112 $ into $ 21 $ and $ 1 $,and their sum is $ 21 + 1 = 22 $. In the second example,it is optimal to split $ 233 $ into $ 2 $ and $ 33 $,and their sum is $ 2 + 33 = 35 $. In the third example,it is impossible to split single digit $ 1 $ into two parts. 
   
   
    
  
  

Source BestCoder 2nd Anniversary
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
#include<list>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
const int maxn = 10000010;
char str[maxn];
int num[10];
int ans[maxn];
int main()
{
    int t,n;cin>>t;
    while(t--){
        scanf("%s",str);
        n=strlen(str);
        memset(num,sizeof(num));
        for(int i=0;i<n;++i){
            num[str[i]-'0']++;
        }
        if(n-num[0]<=1){
            printf("Uncertainn");
            continue;
        }
        int cnt,x=0;
        for(int i=1;i<=9;++i){
            if(num[i]){
                cnt=i;num[i]--;break;
            }
        }
        for(int i=0;i<=9;++i){
            while(num[i]){
                if(i+cnt>=10){
                    int q=(i+cnt)%10;
                    ans[x++]=q;num[i]--;cnt=1;
                }
                else {
                    ans[x++]=i+cnt;
                    num[i]--;cnt=0;break;
                }
            }
            if(cnt==0)break;
        }if(cnt)ans[x++]=1;
        for(int i=9;i>=0;--i){
            while(num[i])printf("%d",i),num[i]--;
        }
        for(int i=x-1;i>=0;--i){
            printf("%d",ans[i]);
        }
        printf("n");
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读