加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 综合聚焦 > 服务器 > 安全 > 正文

HDU 2689 Sort it [树状数组]【数据结构】

发布时间:2020-12-15 05:56:39 所属栏目:安全 来源:网络整理
导读:题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2689 ————————————————————————————-. Sort it Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4140 Accepted

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2689
————————————————————————————-.
Sort it

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4140 Accepted Submission(s): 2945

Problem Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example,1 2 3 5 4,we only need one operation : swap 5 and 4.

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.

Output
For each case,output the minimum times need to sort it in ascending order on a single line.

Sample Input
3
1 2 3
4
4 3 2 1

Sample Output
0
6

Author
WhereIsHeroFrom

Source
ZJFC 2009-3 Programming Contest

————————————————————————————-.

题目大意:
就是问这个序列冒泡排序的话 需要交换多少次

解题思路:
明确题意之后就非常好理解了
对于每个数字来说交换了多少次 也就是在这个数出现之前有几个比他大的数字。累加即可。

这里维护一个树状数组,每次把a[i]的值更新为1,这样的话查询的时候1~a[i]的和就是这个数出现之前比他大的数字的个数。

处理不难 。

附本题代码
———————————-.

#include <bits/stdc++.h>

#define abs(x) (((x)>0)?(x):-(x))
#define lalal puts("*********")
using namespace std;
/**************************************/
const int N = 1000+5;
#define lowbit(x) (x&-x)
int cnt,sum[N],a[N];
void update(int index,int val){
    for(int i=index;i<=cnt;i+=lowbit(i))
        sum[i]+=val;
    return ;
}
int getSum(int index){
    int ans = 0;
    for(int i=index;i>0;i-=lowbit(i))
        ans+=sum[i];
    return ans;
}
int main(){
    while(~scanf("%d",&cnt)){
        memset(sum,0,sizeof(sum));
        for(int i=1;i<=cnt;i++)
            scanf("%d",&a[i]);

        int ans=0;
        for(int i=cnt;i;i--){
            ans+=getSum(a[i]);
            update(a[i],1);
        }
        printf("%dn",ans);
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读