加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 综合聚焦 > 服务器 > 安全 > 正文

HDU 5775 Bubble Sort [树状数组]【数据结构】

发布时间:2020-12-15 05:56:38 所属栏目:安全 来源:网络整理
导读:题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5775 ———————————————————-. Bubble Sort Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 1241 Accepted Submission(s)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5775

———————————————————-.
Bubble Sort

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1241 Accepted Submission(s): 683

Problem Description
P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.

for(int i=1;i<=N;++i)
for(int j=N,t;j>i;—j)
if(P[j-1] > P[j])
t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort,the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N,followed by another line with a permutation of the integers from 1 to N,inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.

Output
For each test case output “Case #x: y1 y2 … yN” (without quotes),where x is the test case number (starting from 1),and yi is the difference of rightmost place and leftmost place of number i.

Sample Input
2
3
3 1 2
3
1 2 3

Sample Output
Case #1: 1 1 2
Case #2: 0 0 0

Hint
In first case,(3,1,2) -> (3,2) -> (1,3,2,3)
the leftmost place and rightmost place of 1 is 1 and 2,2 is 2 and 3,3 is 1 and 3
In second case,the array has already in increasing order. So the answer of every number is 0.

Author
FZU

Source
2016 Multi-University Training Contest 4

———————————————————–.

题目大意:
就是求每个数字在冒泡排序的过程中位置的区间大小

解题思路:
用手写了写 发现结果就是
max(前面有几个比a_i大,后面有几个比a_i小);
其实也很好想 根据冒泡排序的交换规则
很容易的计算每一个数字左移数和右移数
至于结果为什么是二者的最大值 也很好想,
因为两者的差就是a_i-i,画图演示的话就是

其他情况得跟这个差不多 不再赘述/

然后用树状数组维护两遍就行了

附本题代码
—————————————.

#include <bits/stdc++.h>

#define abs(x) (((x)>0)?(x):-(x))
#define lalal puts("*********")
#define Rep(a,b,c) for(int a=(b);a<=(c);a++)
#define Req(a,c) for(int a=(b);a>=(c);a--)
#define Rop(a,c) for(int a=(b);a<(c);a++)
#define s1(a) scanf("%d",&a)
using namespace std;
/**************************************/

const int N = 100000+5;
#define lowbit(x) (x&-x)
int sum[N],cnt,ans[N],a[N];
void update(int index,int val){
    for(int i=index;i<=cnt;i+=lowbit(i))
        sum[i]+=val;
    return;
}

int getSum(int index){
    int ans = 0;
    for(int i=index;i>0;i-=lowbit(i))
        ans+=sum[i];
    return ans;
}

int main(){
    int _,kc,x;
    while(~s1(_)){
        kc=0;
        while(_--){
            s1(cnt);
            memset(sum,0,sizeof(sum));
            memset(ans,sizeof(ans));
            Rep(i,1,cnt){
                s1(a[i]);
                ans[a[i]] =getSum(cnt)-getSum(a[i]);
                update(a[i],1);
            }
            memset(sum,sizeof(sum));
            Req(i,1){
                ans[a[i]] =max(ans[a[i]],getSum(a[i]));
                update(a[i],1);
            }
            printf("Case #%d:",++kc);
            Rep(i,cnt) printf(" %d",ans[i]);
            puts("");
        }
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读