加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 综合聚焦 > 服务器 > Windows > 正文

PAT Advanced 1014 Waiting in Line

发布时间:2020-12-14 06:00:27 所属栏目:Windows 来源:网络整理
导读:Suppose a bank has? N?windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are: The space inside the yellow line in front of eac

Suppose a bank has?N?windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with?Mcustomers. Hence when all the?N?lines are full,all the customers after (and including) the?(st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length,the customer will always choose the window with the smallest number.
  • Customer?i???will take?T?i???minutes to have his/her transaction processed.
  • The first?N?customers are assumed to be served at 8:00am.

Now given the processing time of each customer,you are supposed to tell the exact time at which a customer has his/her business done.

For example,suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1,2,6,4 and 3 minutes,respectively. At 08:00 in the morning,?customer?1???is served at?window?1???while?customer?2???is served at?window?2??.?Customer?3???will wait in front of?window?1???and?customer?4???will wait in front of?window?2??.?Customer?5???will wait behind the yellow line.

At 08:01,?customer?1???is done and?customer?5???enters the line in front of?window?1???since that line seems shorter now.?Customer?2???will leave at 08:02,?customer?4???at 08:06,?customer?3???at 08:07,and finally?customer?5???at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers:?N?(≤,number of windows),?M?(≤,the maximum capacity of each line inside the yellow line),?K?(≤,number of customers),and?Q?(≤,number of customer queries).

The next line contains?K?positive integers,which are the processing time of the?K?customers.

The last line contains?Q?positive integers,which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to?K.

Output Specification:

For each of the?Q?customers,print in one line the time at which his/her transaction is finished,in the format?HH:MM?where?HH?is in [08,17] and?MM?is in [00,59]. Note that since the bank is closed everyday after 17:00,for those customers who cannot be served before 17:00,you must output?Sorry?instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:



维护N个窗口队列,队列中存储每个人的编号和进入队列的时刻(从8:00开始经过的分钟数)。在每个人到来时寻找可入队的队列,若找到则直接入队,若所有队列均满则计算每条队列队首的人的完成时间,将最早完成的那个人出队,并入队新来的人。当所有人都到来后计算剩余队列中所有人的出队时间。最后排除入队时间晚于17:00的人,输出结果。08:07 08:06 08:10 17:00 Sorry
#include <bits/stdc++.h>
using namespace std;
struct cmp
{
    bool operator () (pair<int,int> a,pair<int,int> b)
    {
        if(a.second==b.second)
        {
            return a.first>b.first;
        }else
        {
            return a.second>b.second;
        }
        
    }
};
int main()
{
    int N,M,K,Q,t;

    cin>>N>>M>>K>>Q;
    vector<int> p_times(K+1),f_times(K+1);
    vector<queue<pair<int,int> > > winds(N,queue<pair<int,int> >());
    queue<int> outside;
    priority_queue<pair<int,int>,vector<pair<int,int> >,cmp> mtime;
    for(int i=1;i<=N;i++)
        mtime.push(make_pair(i-1,0));
    for(int i=1;i<=K;i++)
    {
        //cout<<mtime.top().first<<‘ ‘<<mtime.top().second<<endl;
        cin>>t;
        p_times[i]=t;
        bool hasIn=false;
        int mincnt=M,minptr=-1;
        for(int j=0;j<N;j++)
        {
            if(winds[j].size()<M)
            {
                if(mincnt>winds[j].size())
                {
                    mincnt=winds[j].size();
                    minptr=j;
                }
                
            }
        }
        if(minptr!=-1)
        {
            winds[minptr].push(make_pair(i,0));
            hasIn=true;
        }
        
        
        if(!hasIn)
        {
            priority_queue<pair<int,cmp> tmp;
            for(int j=0;j<N;j++)
            {
                if(!winds[j].empty())
                tmp.push(make_pair(j,p_times[winds[j].front().first]+winds[j].front().second));
            }
            pair<int,int> ans=tmp.top();
            //cout<<ans.first<<‘ ‘<<winds[ans.first].front().first<<‘ ‘<<ans.second<<endl;
            f_times[winds[ans.first].front().first]=ans.second;
            winds[ans.first].pop();
            winds[ans.first].push(make_pair(i,ans.second));
            winds[ans.first].front().second=ans.second;
        }
    }
    int cnt=0;
    for(int i=0;i<N;i++)
    {
        cnt+=winds[i].size();
    }
    //cout<<cnt<<endl;
    for(int i=0;i<cnt;i++)
    {
        priority_queue<pair<int,int> ans=tmp.top();
            //cout<<ans.first<<‘ ‘<<winds[ans.first].front().first<<‘ ‘<<ans.second<<endl;
            f_times[winds[ans.first].front().first]=ans.second;
            winds[ans.first].pop();
            winds[ans.first].front().second=ans.second;
    }
    for(int i=1;i<=Q;i++)
    {
        cin>>t;
        int HH=f_times[t]/60+8;
        int MM=f_times[t]%60;
        int pre=f_times[t]-p_times[t];
        int PHH=pre/60+8;
        int PMM=pre%60;
        if(PHH>=17)
        {
            cout<<"Sorry"<<endl;
        }else
        {
            printf("%02d:%02dn",HH,MM);
        }
        
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读