加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 编程开发 > Java > 正文

Almost Sorted Array(o(nlgn)求解LIS)

发布时间:2020-12-15 07:35:10 所属栏目:Java 来源:网络整理
导读:Almost Sorted Array Time Limit: 4000/2000 MS (Java/Others)????Memory Limit: 262144/262144 K (Java/Others) Total Submission(s): 10562????Accepted Submission(s): 2449 Problem Description We are all familiar with sorting algorithms: quick sor

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)????Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 10562????Accepted Submission(s): 2449


Problem Description
We are all familiar with sorting algorithms: quick sort,merge sort,heap sort,insertion sort,selection sort,bubble sort,etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it,and the remaining array is sorted. Now you are given an array? a1,a2,,an,is it almost sorted?
?

?

Input
The first line contains an integer? T?indicating the total number of test cases. Each test case starts with an integer?n?in one line,then one line with?n?integers?a1,a2,,an.

1T2000
2n105
1ai105
There are at most 20 test cases with?n>1000.
?
Output
For each test case,please output "`YES`" if it is almost sorted. Otherwise,output "`NO`" (both without quotes).
?

?

Sample Input
3
3
2 1 7
3
3 2 1
5
3 1 4 1 5
?

?

Sample Output
YES
YES
NO
?

?

Source
2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)
?

?

Recommend
hujie

onlgn求解LIS的基本思想是,用dp[i]保存长度为i的最长子序列的最大值的最小值。
遍历数组,如果a >= dp[len],接到后面,否则,在dp中寻找第一个大于这a的数,把他替换掉,原因很好想,要想使得序列足够长,那么dp[i]越小越好。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 100000 + 5;

int n,val[maxn];
int cnt1,cnt2,dp[maxn];

int main() {
   int t;
   int a,temp;
   scanf("%d",&t);
   while(t --) {
      cnt1 = 0,cnt2 = 0;
      memset(dp,0,sizeof dp);
      scanf("%d",&n);
      for(int i = 0; i < n; i ++) scanf("%d",&val[i]);
      for(int i = 0; i < n; i ++) {
         if(val[i] >= dp[cnt1]) dp[++ cnt1] = val[i];
         else {
            temp = upper_bound(dp + 1,dp + 1 + cnt1,val[i]) - dp;
            dp[temp] = val[i];
         }
      }
      memset(dp,sizeof dp);
      for(int i = n - 1; i >= 0; i --) {
         if(val[i] >= dp[cnt2]) dp[++ cnt2] = val[i];
         else {
            temp = upper_bound(dp + 1,dp + 1 + cnt2,val[i]) - dp;
            dp[temp] = val[i];
         }
      }
      if(cnt1 >= n - 1 || cnt2 >= n - 1) printf("YESn");
      else printf("NOn");
   }
   return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读