加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 站长学院 > PHP教程 > 正文

kmp(多次可重叠匹配)

发布时间:2020-12-13 22:17:16 所属栏目:PHP教程 来源:网络整理
导读:http://acm.hdu.edu.cn/showproblem.php?pid=1686 Oulipo ? Problem Description The French author Georges Perec (1936–1982) once wrote a book,La disparition,without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

http://acm.hdu.edu.cn/showproblem.php?pid=1686

Oulipo

?

Problem Description
The French author Georges Perec (1936–1982) once wrote a book,La disparition,without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal,mais tout s’affirmait faux. Tout avait Fair normal,d’abord,puis surgissait l’inhumain,l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis,assaillant à tout instant son imagination,l’intuition d’un tabou,la vision d’un mal obscur,d’un quoi vacant,d’un non-dit : la vision,l’avision d’un oubli commandant tout,où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather,low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences,in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word,i.e.,a given string,occurs in a text. More formally: given the alphabet {‘A‘,‘B‘,‘C‘,…,‘Z‘} and two finite strings over that alphabet,a word W and a text T,count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

?

?

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W,a string over {‘A‘,‘Z‘},with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T,with |W| ≤ |T| ≤ 1,000,000.
?

?

Output
For every test case in the input file,the output should contain a single number,on a single line: the number of occurrences of the word W in the text T.

?

?

Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
?

?

Sample Output
1 3 0
?

?

Source
华东区大学生程序设计邀请赛_热身赛
?

?

Recommend
lcy???|???We have carefully selected several similar problems for you:?? 1358? 3336? 3746? 2203? 2222
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <algorithm>
#include <iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include <stdio.h>
#include <string.h>
using namespace std;
const int N = 500009 ;
int c[N] ;
int n ;
//int p[220009] ;
char a[1000009] ;
char b[10009];


void getnext(char *b,int *next)
{
    int len = strlen(b);
    int j = 0,k = -1 ;
    next[0] = -1 ;
    while(j < len)//查找多次且可重叠时len不能减一,因为该单词的末尾加一的next也需要被下一次查询用到。
    {
        if(k == -1 || b[k] == b[j])
        {
            k++;
            j++;
            // 下面nest数组的优化
            if(b[k] != b[j])
                next[j] = k ;
            else
                next[j] = next[k];
        }
        else
        {
            k = next[k];
        }
    }
}

int main()
{
    int n ;
    scanf("%d",&n);
    while(n--)
    {
        int next[10009];
        scanf("%s",b);
        scanf("%s",a);
        int lena = strlen(a),lenb = strlen(b);
        getnext(b,next);
        int i = 0,j = 0;
        int ans = 0 ;
        while(i < lena)
        {
            if(j == -1 || a[i] == b[j])
            {
                i++ ;
                j++ ;
            }
            else
            {
                j = next[j];
            }
            if(j == lenb)
            {
                ans++;
                j = next[j] ;
            }
        }
        printf("%dn",ans);
    }



    return 0 ;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读