POJ 3624 Charm Bracelet【01背包入门题】
Charm Bracelet
Description Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course,she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi≤ 400),a 'desirability' factor Di (1 ≤ Di ≤ 100),and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880). Given that weight limit as a constraint and a list of the charms with their weights and desirability rating,deduce the maximum possible sum of ratings. Input * Line 1: Two space-separated integers: N and M Output * Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints Sample Input 4 6
1 4
2 6
3 12
2 7
Sample Output 23
Source
USACO 2007 December Silver
原题链接:http://poj.org/problem?id=3624
01背包入门题,不解释。 #include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=12880+5;
int v[maxn];
int w[maxn];
int dp[maxn];
int main()
{
int n,m;
ios::sync_with_stdio(false);
cin.tie(0);
//freopen("data/3624.txt","r",stdin);
while(cin>>n>>m)
{
for(int i=0; i<n; i++)
cin>>w[i]>>v[i];
memset(dp,sizeof(dp));
for(int i=0; i<n; i++)
{
for(int j=m; j>=w[i]; j--)
{
dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
}
}
cout<<dp[m]<<endl;
}
return 0;
}
(编辑:李大同) 【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容! |