HDU 4810 Wall Painting(组合数学 + 位运算)——2013ACM/ICPC
发布时间:2020-12-13 21:16:05 所属栏目:PHP教程 来源:网络整理
导读:传送门 Wall Painting Time Limit: 10000/5000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2627Accepted Submission(s): 839 Problem Description Ms.Fang loves painting very much. She paints GFW(Great Funny Wal
传送门 Wall PaintingTime Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2627 Accepted Submission(s): 839 Problem Description Ms.Fang loves painting very much. She paints GFW(Great Funny Wall) every day. Every day before painting,she produces a wonderful color of pigments by mixing water and some bags of pigments. On the K-th day,she will select K specific bags of pigments and mix them to get a color of pigments which she will use that day. When she mixes a bag of pigments with color A and a bag of pigments with color B,she will get pigments with color A xor B. When she mixes two bags of pigments with the same color,she will get color zero for some strange reasons. Now,her husband Mr.Fang has no idea about which K bags of pigments Ms.Fang will select on the K-th day. He wonders the sum of the colors Ms.Fang will get with
For example,assume n = 3,K = 2 and three bags of pigments with color 2,1,2. She can get color 3,3,0 with 3 different plans. In this instance,the answer Mr.Fang wants to get on the second day is 3 + 3 + 0 = 6. Mr.Fang is so busy that he doesn’t want to spend too much time on it. Can you help him? You should tell Mr.Fang the answer from the first day to the n-th day. Input There are several test cases,please process till EOF. For each test case,the first line contains a single integer N(1 <= N <= 103).The second line contains N integers. The i-th integer represents the color of the pigments in the i-th bag. Output For each test case,output N integers in a line representing the answers(mod 106 +3) from the first day to the n-th day. Sample Input
Sample Output
题目大意: 给定 解题思路: 首先将每个数的2进制求出来,在每位2进制数中求出
每次选奇数个 奇数个 次幂, 是任意 /**
2016 - 09 - 20 晚上
Author: ITAK
Motto:
本日的我要超出昨日的我,明日的我要胜过本日的我,
以创作出更好的代码为目标,不断地超出自己。
**/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
const int INF = 1e9+5;
const int MAXN = 1e3+5;
const int MOD = 1e6+3;
const double eps = 1e⑺;
const double PI = acos(-1);
using namespace std;
int Scan_Int()///输入外挂
{
int res = 0,ch,flag = 0;
if((ch=getchar()) == '-')
flag = 1;
else if(ch >= '0' && ch<='9')
res = ch-'0';
while((ch=getchar())>='0' && ch<='9')
res = res*10+ch-'0';
return flag?-res:res;
}
LL Scan_LL()///输入外挂
{
LL res=0,flag=0;
if((ch=getchar())=='-')
flag=1;
else if(ch>='0'&&ch<='9')
res=ch-'0';
while((ch=getchar())>='0'&&ch<='9')
res=res*10+ch-'0';
return flag?-res:res;
}
void Out(int a)///输出外挂
{
if(a>9)
Out(a/10);
putchar(a%10+'0');
}
LL c[MAXN][MAXN];
void Init()
{
c[0][0] = 1;
for(int i=1; i<MAXN; i++)
c[i][0] = 1;
for(int i=1; i<MAXN; i++)
for(int j=1; j<MAXN; j++)
c[i][j] = (c[i-1][j-1] + c[i-1][j]) % MOD;
}
LL a[MAXN];
int cnt[70];
int main()
{
Init();
int n;
while(~scanf("%d",&n))
{
for(int i=0; i<n; i++)
scanf("%I64d",&a[i]);
memset(cnt,0,sizeof(cnt));
for(int i=0; i<n; i++)
{
LL tp = a[i];
for(int j=0; j<63; j++)
{
if(tp & 1)
cnt[j]++;
tp>>=1;
}
}
for(int i=1; i<=n; i++)
{
LL sum = 0;
for(int j=0; j<63; j++)
{
if(cnt[j])
{
for(int k=1; k<=i; k+=2)
{
if(cnt[j]>=k && (n-cnt[j]>=i-k))
{
sum += ((c[cnt[j]][k]*c[(n-cnt[j])][i-k]%MOD)*(1LL<<j)%MOD);
sum %= MOD;
}
}
}
}
if(i != n)
cout<<sum<<" ";
else
cout<<sum<<endl;
}
}
return 0;
}
(编辑:李大同) 【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容! |