[poj 1201]Intervals 差分约束
题目:http://poj.org/problem?id=1201 Intervals Description You are given n closed,integer intervals [ai,bi] and n integers c1,…,cn. Input The first line of the input contains an integer n (1 <= n <= 50000) – the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai,bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1. Output The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai,n. Sample Input Sample Output 题意:要求满足bi-ai选数>=ci 中最小的集合; 思路: s[bi]-s[ai-1]>=ci;(题)
s[I+1]-s[I]>=0;(本身)
s[I+1]-s[I]<=1;-->s[l]-s[I+1]>=-1(本身) 用最小值建边spfa求maxn-minn的最长路便可; 代码: #include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int head[60005],val[160005];
int tot,to[160005],nex[160005];
int n;
int aa,bb,cc;
queue<int> q;
int d[60005];
int vis[60005];
void spfa(int x)
{
memset(d,-1,sizeof(d));
d[x]=0;
vis[x]=1;
q.push(x);
while(!q.empty())
{
int now=q.front();
q.pop();
vis[now]=0;
for(int i=head[now];i!=-1;i=nex[i])
{
int v=to[i];
if(d[v]==-1||d[v]<d[now]+val[i])
{
d[v]=d[now]+val[i];
if(!vis[v])
{
vis[v]=1;
q.push(v);
}
}
}
}
}
void add(int x,int y,int v)
{
int tmp=head[x];
head[x]=++tot;
nex[tot]=tmp;
to[tot]=y;
val[tot]=v;
}
int main()
{
scanf("%d",&n);
int minn=10000000;
int maxn=-10000000;
memset(head,sizeof(head));
for(int i=1;i<=n;i++)
{
scanf("%d%d%d",&aa,&bb,&cc);
aa--;
add(bb,aa,cc);
minn=min(aa,minn);
maxn=max(maxn,bb);
}
for(int i=minn;i<maxn;i++)
{
add(i+1,i,0);
add(i,i+1,-1);
}
spfa(maxn);
printf("%dn",d[minn]);
} (编辑:李大同) 【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容! |