1035. Password (20)
To prepare for PAT,the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase),or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @,0 (zero) by %,l by L,and O by o. Now it is your job to write a program to check the accounts generated by the judge,and to help the juge modify the confusing passwords. Input Specification: Each input file contains one test case. Each case contains a positive integer N (<= 1000),followed by N lines of accounts. Each account consists of a user name and a password,both are strings of no more than 10 characters with no space. Output Specification: For each test case,first print the number M of accounts that have been modified,then print in the following M lines the modified accounts info,that is,the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified,print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However,if N is one,you must print "There is 1 account and no account is modified" instead. Sample Input 1: 3 Team000002 Rlsp0dfa Team000003 perfectpwd Team000001 R1spOdfa Sample Output 1: 2 Team000002 RLsp%dfa Team000001 R@spodfa Sample Input 2: 1 team110 abcdefg332 Sample Output 2: There is 1 account and no account is modified Sample Input 3: 2 team110 abcdefg222team220 abcdefg333 Sample Output 3: There are 2 accounts and no account is modified
#include <iostream>
#include <string>
using namespace std;
struct user {
string name;
string password;
bool flag;
};
bool password(user &a) {
int i;
bool flag = false;
for(i = 0 ; i < a.password.length(); i++) {
switch(a.password[i]) {
case '1': flag = true; a.password[i] = '@'; break;
case '0': flag = true; a.password[i] = '%'; break;
case 'l': flag = true; a.password[i] = 'L'; break;
case 'O': flag = true; a.password[i] = 'o'; break;
default: continue;
}
}
return flag;
}
int main() {
struct user user[1001];
int n,i;
while(cin>>n) {
int count = 0;
for(i=0; i<n; i++) {
cin>>user[i].name>>user[i].password;
user[i].flag = false;
}
for(i=0; i<n; i++) {
if(password(user[i])) {
user[i].flag = true;
count++;
}
}
if(count>0) {
cout<<count<<endl;
for(i=0; i<n; i++) {
if(user[i].flag) {
cout<<user[i].name<<" "<<user[i].password<<endl;
}
}
} else {
if(n == 1) {
cout<<"There is 1 account and no account is modified"<<endl;
} else {
cout<<"There are "<<n<<" accounts and no account is modified"<<endl;
}
}
}
return 0;
} (编辑:李大同) 【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容! |