加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

Global Roaming

发布时间:2020-12-16 22:47:35 所属栏目:大数据 来源:网络整理
导读:G: Global Roaming Time Limit: 1000 ms Case Time Limit: 1000 ms Memory Limit: 65536 KB Submit: 0 Accepted: 0 Description A great deal in today's mobile communication depends on having a direct view to a satellite. For communication provider

G: Global Roaming


Time Limit: 1000 ms Case Time Limit: 1000 ms Memory Limit: 65536 KB
Submit: 0 Accepted: 0

Description


A great deal in today's mobile communication depends on having a direct view to a satellite. For communication providers it is therefore crucial to know where their services are available.
You are to identify locations which have a direct view to a particular satellite,i.e. this satellite must be above the horizon. To make things easier you may assume that the earth is a perfect sphere with a radius of 6378 km (mountains will be added next year...). The satellite is a pointlike object above the earth's surface.

Input


The input file consists of several test cases. For each test case the first line contains the number of locations n to be checked followed by the position of the satellite: its latitude,its longitude (both in degrees) and its height (in km) above the earth's surface.
Each of the following n lines contains a location on the earth's surface: the location's label (a sequence of less than 60 printable ASCII characters containing no whitespace characters) followed by its latitude and longitude (both in degrees).
Input is terminated by n=0.

Output


For each test case output the number of the test case as formatted in the sample output. Then,output the locations from where the satellite is visible by printing the corresponding labels on separate lines in the same order as they appear in the input file.
Output a blank line after each test case.

Sample Input


3 20.0 -60.0 150000000.0
Ulm       48.406    10.002
Jakarta   -6.13     106.75
Honolulu  21.32    -157.83
2 48.4 10 0.5
Ulm       48.406    10.002
Honolulu  21.32    -157.83
0 0.0 0.0 0.0

Sample Output


Test case 1:
Ulm
Honolulu

Test case 2:
Ulm
看了Johnson法则的相关内容,推导了一个下午才推出结论,之后就轻松AC了


建议先看一下前一篇博文:Johnson法则——流水作业调度——动态规划


code:


#include <stdio.h>

#include <string.h>

#include <stdlib.h>

#define le 10001

int ar[le],br[le],c[le];

typedef struct{

    int num,mn,flag;

}re;

re f[le];

int n;

 

int cmp(const void *va,const void *vb){

    return (*(re *)va).mn > (*(re *)vb).mn ? 1 : -1;

}

 

int min(int va,int vb){

    return va < vb ? va : vb;

}

 

void input(){

    int i;

    for(i = 0;i < n;i++)

        scanf("%d%d",&ar[i],&br[i]);

}

 

void init(){

    inti,left=0,right=n;

    for(i = 0;i < n;i++){

        f[i].num = i;

        f[i].mn = min(ar[i],br[i]);

        f[i].flag = ar[i] <= br[i];

    }

    qsort(f,n,sizeof(f[0]),cmp);

    for(i = 0;i < n;i++)

        if(f[i].flag)   c[left++] = f[i].num;

        else      c[--right] = f[i].num;

}

 

int getvalue(){

    int i,p = 0,sum = 0;

    for(i = 0;i < n;i++){

        p += ar[c[i]];

        sum = (p >= sum ? p +br[c[i]] : sum + br[c[i]]);

    }

    return sum;

}

 

void deal(){

    int ans;

    init();

    ans=getvalue();

    printf("%dn",ans);

}

 

int main(void){

    while(scanf("%d",&n)==1 && n){

        input();

        deal();

    }

    return 0;

} 

  


 


(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读