加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

POJ 1007 DNA Sorting

发布时间:2020-12-16 22:31:38 所属栏目:大数据 来源:网络整理
导读:DNA Sorting Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 63725 Accepted: 25159 Description One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For
DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 63725 Accepted: 25159

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance,in the letter sequence ``DAABEC'',this measure is 5,since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A,C,G,and T). However,you want to catalog them,not in alphabetical order,but rather in order of ``sortedness'',from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines,each containing a string of length n.

Output

Output the list of input strings,arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted,then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

c++代码:

#include<iostream>
#include<cstring>
#include<cstdlib>
using namespace std;
const int MAX=105;

struct DNA{

char str[55];
int measures;

};

int dlen(char *str){
int cnt=0;
for(int i=0;i<strlen(str);i++)
for(int j=i+1;j<strlen(str);j++){
if(str[i]>str[j])cnt++;

}
return cnt;
}

DNA dna[MAX];

int cmp(const void *va,const void *vb){

DNA*a,*b;
a=(DNA*)va;
b=(DNA*)vb;
if(a->measures > b->measures)return 1;
else if(a->measures < b->measures)return -1;

return 0;

}

int main(){

int len,n;
cin>>len>>n;
for(int i=0;i<n;i++){cin>>dna[i].str;dna[i].measures=dlen(dna[i].str);}
qsort(dna,n,sizeof(DNA),cmp);

for(int i=0;i<n;i++)cout<<dna[i].str<<endl;


return 0;
}

java代码如下:

import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;

public class Main {

private String str;
private int cnt;

public void len() {

int size = str.length();
for (int i = 0; i < size; i++)
for (int j = i + 1; j < size; j++) {
if (str.charAt(i) > str.charAt(j))
this.cnt++;

}

}

public Main() {
this.cnt = 0;
}

public static void main(String[] args) {
Scanner in = new Scanner(System.in);

int len = in.nextInt();
int n = in.nextInt();
Main[] dnaSortings = new Main[n];
for (int i = 0; i < n; i++) {
dnaSortings[i]=new Main();
}
for (int i = 0; i < n; i++) {
dnaSortings[i].str = in.next();
dnaSortings[i].len();
}
Comparator<? super Main> c = new Comparator<Main>() {

@Override
public int compare(Main o1,Main o2) {
if (o1.cnt > o2.cnt) {
return 1;
} else if (o1.cnt < o2.cnt) {
return -1;

}
return 0;
}
};
Arrays.sort(dnaSortings,c);

for (int i = 0; i < n; i++) {
System.out.println(dnaSortings[i].str);
}

} }

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读