加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

[kuangbin带你飞]专题十二 基础DP1 B - Ignatius and the Prince

发布时间:2020-12-14 05:11:18 所属栏目:大数据 来源:网络整理
导读:B - Ignatius and the Princess IV 题目链接:https://vjudge.net/contest/68966#problem/B 题目: "OK,you are not too bad,em... But you can never pass the next test." feng5166 says. "I will tell you an odd number N,and then N integers. There wi

B - Ignatius and the Princess IV

题目链接:https://vjudge.net/contest/68966#problem/B

题目:

"OK,you are not too bad,em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N,and then N integers. There will be a special integer among them,you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can‘t find the right integer,I will kill the Princess,and you will be my dinner,too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?

InputThe input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
OutputFor each test case,you have to output only one line which contains the special number you have found.
Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1
Sample Output
3
5
题意:给你一些数,求出那个出现次数大于等于(n+1)/2的数
思路:用map来记录每个数出现了几次

//
// Created by hanyu on 2019/8/4.
//
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <set>
#include<math.h>
#include<map>
using namespace std;
typedef long long ll;
const int maxn=1e6+10;
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int a[maxn];
        map<int,int>mp;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            mp[a[i]]++;
        }
        int m=(n+1)/2;
        for(auto it:mp)
        {
            if(it.second>=m)
            {
                printf("%dn",it.first);
                break;
            }
        }
    }
    return 0;
}

?

1

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读