加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

^&^

发布时间:2020-12-14 05:08:38 所属栏目:大数据 来源:网络整理
导读:Problem Description Bit operation is a common computing method in computer science,Now we have two positive integers? A ?and? B ?,Please find a positive integer? C ?that minimize the value of the formula? ( A ? ? x o r ? ? C ) ? ? ? ? ( B
Problem Description
Bit operation is a common computing method in computer science,Now we have two positive integers? A?and?B?,Please find a positive integer?C?that minimize the value of the formula?(A??xor??C)??&??(B??xor??C)?.Sometimes we can find a lot of?C?to do this,So you need to find the smallest?C?that meets the criteria .

For example,Let‘s say?A?is equal to 5 and?B?is equal to 3,we can choose?C=1,3....,so the answer we‘re looking for?C?is equal to 1.

If the value of the expression is 0 when C=0,please print 1.
?

?

Input
The input file contains? T?test samples.(1<=T<=100)

The first line of input file is an integer?T.

Then the?T?lines contains 2 positive integers,?A?and?B,(1A,B<232)
?

?

Output
For each test case,you should output the answer and a line for each answer.
?

?

Sample Input
1 3 5
?

?

Sample Output
1
?
#include <bits/stdc++.h>

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
#include <cstring>
#include <cstdlib>
#include <map>
#include <vector>
#include <set>
#include <queue>
#include <stack>
#include <cmath>
typedef long long ll;
using namespace std;
const int INT=1e6+5;
#define lson rt<<1,l,m  
#define rson rt<<1|1,m+1,r
#define read(x) scanf("%d",&x)
#define lread(x) scanf("%lld",&x);
#define pt(x) printf("%dn",(x))
#define cn cin>>
#define ct cout<<
#define en <<endl
#define rep(j,k) for (int i = (int)(j); i <= (int)(k); i++)
#define mem(s,t) memset(s,t,sizeof(s))
#define re return 0;


typedef long long ll;

int main()
{
    ll t,n,m,k;
    cn t ;
    while(t--)
    {
        cn n>>m;
        if(n&m) ct (n&m) en;
        else ct 1 en ;

    }
    re 
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读