加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU1002 A + B Problem II【大数】

发布时间:2020-12-14 05:03:31 所属栏目:大数据 来源:网络整理
导读:A + B Problem II Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 371486????Accepted Submission(s): 72398 Problem Description I have a very simple problem for you. Given two integers

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 371486????Accepted Submission(s): 72398


Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
?

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
?

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
?

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
?

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 2222222222222221110

问题链接:HDU1002 A + B Problem II

问题简述:参见上文。

问题分析这个问题是要计算两个数相加的结果,问题是每个数的长度不超过1000,也就是数可能非常大,所有需要用大数加法来做。

程序说明:程序中处处都是基本的套路,需要熟练掌握。

题记:程序需要写得简洁易懂。


参考链接:(略)


AC的C++语言程序如下:

/* HDU1002 A + B Problem II */

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

const int BASE = 10;
const int N = 1000;
char sa[N+1],sb[N+1];
int a[N+1],b[N+1];

int main()
{
    int t;

    scanf("%d",&t);

    for(int k=1; k<=t; k++) {
        scanf("%s%s",sa,sb);

        // 字符串转数值数组
        memset(a,sizeof(a));
        memset(b,sizeof(b));
        int alen = strlen(sa);
        for(int i=alen-1,j=0; i>=0; i--,j++)
            a[j] = sa[i] - '0';
        int blen = strlen(sb);
        for(int i=blen-1,j++)
            b[j] = sb[i] - '0';

        // 相加(需要考虑进位问题)
        int len = max(alen,blen);
        int carry = 0;
        for(int i=0; i<len; i++) {
            a[i] += b[i] + carry;
            carry = a[i] / BASE;
            a[i] %= BASE;
        }
        if(carry > 0)
            a[len++] = carry;

        // 输出结果(需要注意输出格式:隔行输出)
        if(k != 1)
            printf("n");
        printf("Case %d:n",k);
        printf ("%s + %s = ",sb);
        for(int i=len-1; i>=0; i--)
            printf("%d",a[i]);
        printf("n");
    }

    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读