加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

【PAT】1024. Palindromic Number (25)

发布时间:2020-12-14 04:52:15 所属栏目:大数据 来源:网络整理
导读:题目 链接: A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example,1234321 is a palindromic number. All single digit numbers are palindromic numbers. Non-palindromic numbers ca

题目


链接:

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example,1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First,the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number,this is repeated until it gives a palindromic number. For example,if we start from 67,we can obtain a palindromic number in 2 steps: 67 + 76 = 143,and 143 + 341 = 484.

Given any positive integer N,you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K,where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case,output two numbers,one in each line. The first number is the paired palindromic number of N,and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps,just output the number obtained at the Kth step and K instead.

Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3




分析


题意:

判断是不是回文数

1. 是
    output 最终数 和 花费的步数
2. 不是
    直至为回文数或步数消耗完
    output: 最终数 和 总步数

坑点:

根据数据规模,这题是大数。凡凡使用字符数组记录数,然后来计算
比如用例 : 196 100

这里写图片描述




题解(已AC)


/** 2018.1.30 Donald */
//1024. Palindromic Number (25)

/** 判断是不是回文数 1. 是 output 最终数 和 花费的步数 2. 不是 直至为回文数或步数消耗完 output: 最终数 和 总步数 */

#include<cstdio>
#include<cstring>
#include<cmath>
#include<stack>
using namespace std;
#define MAXN 5000

int sum;
char str[5000];
char rev[5000];
stack<char> Stack;

bool isParlindromic() {

    int len = strlen(str);

    for (int i = 0 ;i < len / 2; ++i) {
        if (str[i] != str[len - i - 1]) {
            return false;
        }
    }

    return true;
}

void reverseStr() {
    int len = strlen(str);

    for (int i = 0; i < len; ++i) {
        rev[i] = str[len - i - 1];
    }
}

void addReverse() {
    int temp = 0;
    int in = 0;
    int len =strlen(str);

    for (int i = len - 1 ; i >= 0 ; --i) {
        temp = (str[i] - '0') + (rev[i] - '0') + in;
        Stack.push((temp % 10) + '0');
        in = temp / 10;
    }

    if (in != 0) {
        Stack.push(in + '0');
    }

    int j = 0;
    while (!Stack.empty()) {
        str[j++] = Stack.top();
        Stack.pop();
    }

}

int main(void) {

    scanf("%s %d",&str,&sum);

    int cnt = 0;

    while (!isParlindromic() && cnt != sum) {

        reverseStr();

        addReverse();

        cnt ++;
    }

    printf("%sn%d",str,cnt);

    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读