加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

POJ2635--The Embarrassed Cryptographer--大数取模

发布时间:2020-12-14 04:13:06 所属栏目:大数据 来源:网络整理
导读:Description The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users,which is now in use in his company. The cryptographic keys are created from the product of two pr

Description

The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users,which is now in use in his company. The cryptographic keys are created from the product of two primes,and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of,was that both factors in a key should be large,not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired,Odd Even secretly goes through all the users keys,to check if they are strong enough. He uses his very poweful Atari,and is especially careful when checking his boss' key.

Input

The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10 100 and 2 <= L <= 10 6. K is the key itself,a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.

Output

For each number K,if one of its factors are strictly less than the required L,your program should output "BAD p",where p is the smallest factor in K. Otherwise,it should output "GOOD". Cases should be separated by a line-break.

Sample Input

143 10
143 20
667 20
667 30
2573 30
2573 40
0 0

Sample Output

GOODBAD 11GOODBAD 23GOODBAD 31

/*
我觉得先筛选出素数,用个数组来存100W内的素数
然后循环一遍,如果有整除的。就不行
注意得转换为1000进制,10进制取模太多次。会超时
*/
#include<iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 1000000
#define inf 0x3f3f3f3f
bool isp[maxn+20];
int pri[maxn];
int kt[10000];//把所输入的数转换为千进制
void init()
{
	for(int i=2;i<=1000;i++)
	{
		if(!isp[i])
		{
			for(int j=i*i;j<=maxn;j+=i)
			{
				isp[j]=1;
			}
		}
	}
	int k=0;
	for(int i=2;i<=maxn;i++)
	{
		if(!isp[i])
		{
			pri[k++]=i;
		}
	}
	pri[k]=inf;
}
int main()
{
	char A[120];
	int m;
	init();
	while(scanf("%s%d",A,&m)==2&&(m))
	{
		bool flag=false;
		int len=strlen(A);
		int i=0,j=-1;
		while(A[i]!='')
		{
			j++;
			kt[j]=A[i]-'0';
			i++;
			if(A[i]!='')
			{
				kt[j]=kt[j]*10+A[i]-'0';
				i++;
				if(A[i]!='')
				{
					kt[j]=kt[j]*10+A[i]-'0';
					i++;
				}
				else break;
			}
			else break;
		}
		//j从1开始
		for(int k=0;pri[k]<m;k++)
		{
			int ans=0;
			for(int z=0;z<=j;z++)
			{
				if(z<j)
			//	ans=(int)(((long long)ans*1000+kt[z])%pri[k]);额。原先照抄LRJ的模板。类型转换费时间严重。直接双倍的时间
				ans=(ans*1000+kt[z])%pri[k];
				else if(len%3==1)
				{
					ans=(ans*10+kt[z])%pri[k];
				}
				else if(len%3==2)ans=(ans*100+kt[z])%pri[k];
				else ans=(ans*1000+kt[z])%pri[k];
			}
			if(!ans)
			{
				printf("BAD %dn",pri[k]);
				flag=true;
				break;
			}
		}
		if(!flag)printf("GOODn");
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读