加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

Hat's Fibonacci

发布时间:2020-12-14 04:10:31 所属栏目:大数据 来源:网络整理
导读:Hat's Fibonacci Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4997????Accepted Submission(s): 1690 Problem Description A Fibonacci sequence is calculated by adding the previous two

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4997????Accepted Submission(s): 1690


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence,with the first two members being both 1.
F(1) = 1,F(2) = 1,F(3) = 1,F(4) = 1,F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input,and print that Fibonacci number.
?

Input
Each line will contain an integers. Process to end of file.
?

Output
For each case,output the result in a line.
?

Sample Input
  
  
100
?

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data,ie. F(20) = 66526 has 5 digits.
?
#include<stdio.h>
long a[8000][800];
int main()
{
	long n,i,j,k;
	a[1][0]=1;
	a[2][0]=1;
	a[3][0]=1;
	a[4][0]=1;
	k=0;
	for(i=5;i<8000;i++)
		for(j=0;j<800;j++)
		{
			k+=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j];
			a[i][j]=k%10000;
			k/=10000;
		}
	while(k)
	{
		a[i][j++]=k%10000;
		k/=10000;
	}
	while(scanf("%ld",&n)>0)
	{
		for(i=799;i>=0;i--)
			if(a[n][i]!=0)
				break;
		printf("%ld",a[n][i]);
		for(i--;i>=0;i--)
			printf("%4.4ld",a[n][i]);
		printf("n");
	}
	return 0;
}
 

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读