加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU1042(大数运算)

发布时间:2020-12-14 04:10:29 所属栏目:大数据 来源:网络整理
导读:N! Time Limit: 10000/5000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 41734????Accepted Submission(s): 11606 Problem Description Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N! ? ? In

N!

Time Limit: 10000/5000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41734????Accepted Submission(s): 11606


Problem Description
Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N!
?


?

Input
One N in one line,process to the end of file.
?


?

Output
For each N,output N! in one line.
?


?

Sample Input
  
  
1 2 3
?


?

Sample Output
  
  
1 2 6

?

//开辟数组每位存储一个数位,一次用当前数和每一位相乘,注意进位!

#include<iostream>
using namespace std;
#include<stdio.h>
const int SUB=40000;
int main()
{
    int n,i,j;
    int a[SUB];
    int digit;
    int carry;
    int temp;
    while(scanf("%d",&n)!=EOF)
    {
        a[0]=1;
        digit=1;
        if(n==0||n==1)
        {
            printf("%dn",a[0]);
            continue;
        }
        for(i=2;i<=n;i++)
        {
            for(j=0,carry=0;j<digit;j++)
            {
                temp=a[j]*i+carry;
                a[j]=temp%10;
                carry=temp/10;
            }
            if(carry)
            {
                while(carry)
                {
                    a[j++]=carry%10;
                    carry/=10;
                    digit=j;
                }
            }
        }
        for(i=digit-1;i>=0;i--)
        {
            printf("%d",a[i]);
        }
        printf("n");
    }
    return 0;
}
 

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读