加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdoj1002(大数相加)

发布时间:2020-12-14 04:08:34 所属栏目:大数据 来源:网络整理
导读:http://acm.hdu.edu.cn/showproblem.php?pid=1002 A + B Problem II Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 119434 Accepted Submission(s): 22702 Problem Description I have a very si

http://acm.hdu.edu.cn/showproblem.php?pid=1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 119434 Accepted Submission(s): 22702


Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.


?

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.


?

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.


?

Sample Input
2 1 2 112233445566778899 998877665544332211


?

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 2222222222222221110


?

Author
Ignatius.L
套用模版做的。。。
#include<stdio.h>
#include<string.h>
char
str1 [ 10000 ],str2 [ 10000 ];
char
sum [ 100001 ];
void
jiafa ()
{

? ? ? memset (sum , 0 , sizeof (sum ));
??? int
i ,j ,p ;
??? int
len1 =strlen (str1 ),len2 =strlen (str2 );
??? for
(i = 0 ;i <(len1 >len2 ?len1 :len2 );i ++)
??? {

? ? ? ? ? ? ? str1 [i ]-= '0' ;
? ? ? ? ? ? ? str2 [i ]-= '0' ;
??? }

??? for
(i = 0 ,j =len1 - 1 ;i <j ;i ++,j --)
??? {

??????? char
c =str1 [j ];
? ? ? ? ? ? ? str1 [j ]=str1 [i ];
? ? ? ? ? ? ? str1 [i ]=c ;
??? }

??? for
(i = 0 ,j =len2 - 1 ;i <j ;i ++,j --)
??? {

??????? char
c =str2 [j ];
? ? ? ? ? ? ? str2 [j ]=str2 [i ];
? ? ? ? ? ? ? str2 [i ]=c ;
??? }

??? char
c ;
??? for
(i = 0 ,c = 0 ;i <(len1 >len2 ?len1 :len2 )||c ;i ++)
??? {

??????? if
(i <len1 )
? ? ? ? ? ? ? ? ? ? ? c +=str1 [i ];
??????? if
(i <len2 )
? ? ? ? ? ? ? ? ? ? ? c +=str2 [i ];
? ? ? ? ? ? ? sum [i ]=c % 10 ;
? ? ? ? ? ? ? c /= 10 ;
??? }

??? for
(i =(len1 >len2 ?len1 :len2 )- 1 ;i >= 0 ;i --)
? ? ? ? ? ? ? printf ( "%d" ,sum [i ]);
? ? ? printf ( "n" );
}

int
main ()
{

??? int
n ;
? ? ? scanf ( "%d" ,&n );
??? int
count = 1 ;
??? while
(n --)
??? {

? ? ? ? ? ? ? scanf ( "%s %s" ,str1 ,str2 );
? ? ? ? ? ? ? printf ( "Case %d:n" ,count ++);
? ? ? ? ? ? ? printf ( "%s + %s = " ,str2 );
? ? ? ? ? ? ? jiafa ();
??????? if
(n )
? ? ? ? ? ? ? ? ? ? ? printf ( "n" );
??? }

??? return
0 ; }

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读